Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-3108

[UI] Few Namenode links are not working

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 0.23.0, 0.23.1
    • Fix Version/s: 0.23.4
    • Component/s: namenode
    • Labels:
      None

      Description

      Scenario 1
      ==========

      Once tail a file from UI and click on "Go Back to File View",I am getting HTTP ERROR 404

      Scenario 2
      ===========

      Frequently I am getting following execption If a click on (BrowseFileSystem or anyfile)java.lang.IllegalArgumentException: java.net.UnknownHostException: HOST-10-18-40-24

      1. Scenario2_Trace.txt
        6 kB
        Brahma Reddy Battula

        Issue Links

          Activity

          Brahma Reddy Battula created issue -
          Brahma Reddy Battula made changes -
          Field Original Value New Value
          Attachment Scenario2_Trace.txt [ 12518869 ]
          Brahma Reddy Battula added a comment -

          Attached execption trace for scenario-2

          Uma Maheswara Rao G added a comment -

          Your scenario-1 seems to be the duplicate of HDFS-2025

          Brahma Reddy Battula added a comment -

          Ya..Scenario-1 is same as HDFS-2025..

          amith added a comment -

          Hi Brahma
          Scenario 1 is similar to HDFS-2025
          Scenario 2 is occurring because of the incorrect/no Host Mapping in DN about NN.

          can u please verify and report my observation is correct

          Robert Joseph Evans made changes -
          Fix Version/s 0.23.4 [ 12320242 ]
          Fix Version/s 0.23.3 [ 12320052 ]
          Brahma Reddy Battula made changes -
          Link This issue is related to HDFS-2025 [ HDFS-2025 ]
          Brahma Reddy Battula made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          1131d 3h 55m 1 Brahma Reddy Battula 21/Apr/15 17:46

            People

            • Assignee:
              Unassigned
              Reporter:
              Brahma Reddy Battula
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development