Hi Uma, thanks for the review.
For 1), I removed it since VolumeChoosingPolicy is annotated as private like BlockPlacementPolicy. So it should not be in hdfs-default.xml, which should contain only public APIs. Advanced users could add this property if they want.
For 2), we actually do not yet have a consistent naming convention. For examples, we have FsPermission, FsStatus, FsShell, FsServerDefaults, o.a.h.f.FsConstants, etc. but also FSDataInputStream, FSDataOutputStream, FSNamesystem, FSImage, etc. We had a discussion and I filed
HADOOP-4357 some time back. Most public APIs use FsXxx. I think that FsXxx is preferred over FSXxx. So new classes should be named FsXxx instead.