Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2988

Improve error message when storage directory lock fails

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.2-alpha
    • Component/s: namenode
    • Labels:
    • Hadoop Flags:
      Reviewed

      Description

      Currently, the error message is fairly opaque to a non-developer ("Cannot lock storage" or something). Instead, we should have some improvments:

      • when we create the in_use.lock file, we should write the hostname/PID that locked the file
      • if the lock fails, and in_use.lock exists, the error message should say something like "It appears that another namenode (pid 23423 on host foo.example.com) has already locked the storage directory."
      • if the lock fails, and no lock file exists, the error message should say something like "if this storage directory is mounted via NFS, ensure that the appropriate nfs lock services are running."
      1. HDFS-2988.patch
        9 kB
        Miomir Boljanovic
      2. HDFS-2988.patch
        4 kB
        Miomir Boljanovic
      3. HDFS-2988.patch
        4 kB
        Miomir Boljanovic
      4. HDFS-2988.patch
        5 kB
        Harsh J

        Activity

        Miomir Boljanovic added a comment -

        Hi gentlemen,

        As as an experienced Java developer but novice opensource contributor I still have a bit doubt about how to start.
        I picked out this issue in order to familiarize myself with the the process and to understand mechanics of a commit.
        I wonder therefore, if the issue needs to be assigned to me before I start working on it?

        Cheers,

        Miomir Boljanovic

        Todd Lipcon added a comment -

        Hi Miomir. Thanks for your interest. You can start working on it without it being assigned – though assigning is nice because it signifies that you're working on it. I'll assign this to you.

        Todd Lipcon added a comment -

        Actually it looks like there is an issue with the JIRA which is preventing me from doing so. Feel free to begin working anyway. I'll look into the JIRA issue.

        Miomir Boljanovic added a comment -

        Thanks Todd, glad to be on board!

        Btw, I tried looking up a hadoop util method that returns PID and nodename, could not find any.
        Perhaps someone can correct if I am wrong?

        Otherwise, I consider writing one based on RuntimeMXBean:

        String jvmName = ManagementFactory.getRuntimeMXBean().getName();

        It returns '<pid>@<hostname>' (at least on 1.6 Oracle JDK) , though it's probably no platform-independent way that can be guaranteed to work in all jvm implementations.
        Besides, getting pid and hostanme requires string parsing, that's a bit fragile and should be avoided.

        Any thoughts on that?

        Todd Lipcon added a comment -

        Hi Miomir. I'm not aware of any such method, so I think your MXBean-based solution should be fine.

        Do we need it to be cross-platform consistent? I think we just need something we can display to the user for informational purposes, anyway.

        Miomir Boljanovic added a comment -

        The patch comprises required error message improvements, a new util class for accessing runtime information about running jvm and corresponding test class.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12531135/HDFS-2988.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2609//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2609//console

        This message is automatically generated.

        Todd Lipcon added a comment -

        Hi Miomir, thanks for the patch. A few comments:

        • please make sure your editor is configured for spaces, not tabs, and 2-space indentation. Some of the whitespace is off in the patch you attached.
        • it doesnt look like you're actually writing the locking node's identity into the lock file itself. The "failed to lock" error message is reporting its own PID/host, not the locker's PID/host
        • for the fallback on host name, why not fall back to using the local hostname provided by InetAddress? Or, to make the whole thing a much simpler patch, I think it would be acceptable to just use the RuntimeMXBean.getName() in the message instead of attempting to parse out the pid and host. I think an error message saying "already locked by process 23942@nn1.foo.com" would be clear enough for most people to track down the issue, and then we wouldn't need to add so much code for just this simple improvement.
        Miomir Boljanovic added a comment -

        Hi Todd, Thanks for your comments,

        I take your point, and fully agree with you said, especially about unnecessary complexity that should be avoided,
        Your idea about using outcome of RuntimeMXBean.getName(), directly in the logging statement makes perfectly sense, I would go for it.
        In that case, would accompanying unit test still be required?
        In general, can a patch without unit test be accepted?

        Todd Lipcon added a comment -

        I think you could still write a unit test here – just instantiate a StorageDirectory, lock it, and then try to do the same again. Assert that you get an error message which includes the name of the JVM. See TestCheckpoint.testSecondaryNameNodeLocking for example.

        Miomir Boljanovic added a comment -

        Hi Todd,

        Asserting that error message includes name of the jvm, may not be straightforward in this case.
        In TestCheckpoint.testSecondaryNameNodeLocking test, GenericTestUtils.assertExceptionContains assertion is used to verify error message
        OverlappingFileLockException exception hanlder in tryLock() method however, neither retrows nor wraps root cause exception but returns null.
        Perhaps, I could assert that for given scenario method returns null, but that's not what we are trying to test here?

        Miomir Boljanovic added a comment -

        Hi Todd,

        New patch is available.
        To assert that error message includes JVM name I used GenericTestUtils.LogCapturer.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12533193/HDFS-2988.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 javadoc. The javadoc tool appears to have generated 13 warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.TestDatanodeBlockScanner

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2692//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2692//console

        This message is automatically generated.

        Miomir Boljanovic added a comment -

        Supposedly, previous patch caused org.apache.hadoop.hdfs.TestDatanodeBlockScanner to fail because I wrongly instantiated StorageDirectory
        I realized afterwards that MiniDFSCluster should be used to instantiate StorageDirectory.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12533385/HDFS-2988.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 javadoc. The javadoc tool appears to have generated 2 warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2697//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2697//console

        This message is automatically generated.

        Karthik Kambatla added a comment -

        Hi Miomir

        The patch seems to be generating 2 additional warning messages - can you please verify if it is. Otherwise, looks good.

        Harsh J added a comment -

        I don't think the javadoc warnings are from his patch. I don't see any javadoc warning changes in there:

        +   * Test that, an attempt to lock a storage that is already locked by a nodename,
        +   * logs error message that includes JVM name of the namenode that locked it.
        

        So it is/was probably something on the trunk. In any case, we can make sure to run mvn javadoc:javadoc before committing this.

        Minor nits:

        1. Fix typo in the fail(…) method. It has the word "alreaady" instead of "already"
        2. The file.close() call can perhaps be moved to the finally { … }

          block at the end?

        +1 aside of these minor nits. Thanks!

        Miomir Boljanovic added a comment -

        Hi Karthik and Harsh, thanks for the reviews.
        Should I fix the nits and create another patch?

        Btw, I ran mvn javadoc:javadoc and could not find any javadoc warnings caused directly by the patch.
        Please let me know if I am missing something.

        Cheers,

        Miomir

        Harsh J added a comment -

        Sorry for being unclear - I was going to fix the nits and commit later.

        New patch -> Just fixed the first nit. The second wasn't necessary and involved further refactoring (cause the clauses were returning).

        Committing to 2.x and trunk shortly.

        Harsh J added a comment -

        Committed to branch-2 and trunk. Thank you for your contribution Miomir!

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2499 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2499/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2431 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2431/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2449 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2449/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = FAILURE
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1097 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1097/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = FAILURE
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1130 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1130/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2508 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2508/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2441 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2441/)
        HDFS-2988. Improve error message when storage directory lock fails. Contributed by Miomir Boljanovic. (harsh) (Revision 1358683)

        Result = SUCCESS
        harsh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1358683
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Storage.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCheckpoint.java

          People

          • Assignee:
            Miomir Boljanovic
            Reporter:
            Todd Lipcon
          • Votes:
            0 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development