Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-2962

jsvc needs to be removed from hdfs packaging

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Duplicate
    • 0.23.0
    • None
    • datanode, security
    • None

    Description

      As we discussed at HDFS-2303:

      ... hit the same problem today when I started to try secured DN of 0.23. The shipped jsvc (commons-daemon-1.0.3) with 0.23 doesn't work on my local ubuntu 11.10 (as described by atm, with libcap.2 instead of 1), nor our cluster centos 5 (without any libcap).

      The problem doesn't happen to 0.20.205 (what we use now) since commons-daemon-1.0.2 jsvc binary doesn't link to any libcap (http://archive.apache.org/dist/commons/daemon/binaries/1.0.2/linux/commons-daemon-1.0.2-bin-linux-${os-arch}.tar.gz)

      So the current way - downloading jsvc binary - won't work for 0.23+ secured DN.
      ...

      jsvc shouldn't be bundled with hadoop. Instead, it should be installed by user.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              mingjielai Mingjie Lai
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: