Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-2662

Namenode should log warning message when trying to start on a unformmatted system

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 0.20.203.0
    • Fix Version/s: None
    • Component/s: namenode
    • Environment:

      Single-node cluster on OS X 10.7 (Lion)

      Description

      When you try to start the namenode for a system that does not have a formatted DFS, it fails silently without any indication that the lack of formatting was the problem. I tried to run start-dfs.sh on a single-node cluster with an unformatted HDFS. The namenode failed to start, but generated no warning messages, and its log was empty. After running "hadoop namenode -format" everything worked.

      Details in this thread: http://mail-archives.apache.org/mod_mbox/hadoop-common-user/201112.mbox/%3CCAN9z%2BopAn-t_f3FRC%3DDtV0n0ysoKd3Fek-fJPb68PMThiPooKg%40mail.gmail.com%3E

      This is a difficult problem to diagnose because the namenode gives you no feedback. It would be better if it printed an error message to its log file.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              billmcn William McNeill
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: