Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2553

BlockPoolSliceScanner spinning in loop

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.23.0, 0.24.0
    • Fix Version/s: 0.24.0, 0.23.1
    • Component/s: datanode
    • Labels:
      None

      Description

      Playing with trunk, I managed to get a DataNode in a situation where the BlockPoolSliceScanner is spinning in the following loop, using 100% CPU:
      at org.apache.hadoop.hdfs.server.datanode.DataNode$BPOfferService.isAlive(DataNode.java:820)
      at org.apache.hadoop.hdfs.server.datanode.DataNode.isBPServiceAlive(DataNode.java:2962)
      at org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner.scan(BlockPoolSliceScanner.java:625)
      at org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner.scanBlockPoolSlice(BlockPoolSliceScanner.java:614)
      at org.apache.hadoop.hdfs.server.datanode.DataBlockScanner.run(DataBlockScanner.java:95)

      1. HDFS-2553.patch
        2 kB
        Uma Maheswara Rao G
      2. ASF.LICENSE.NOT.GRANTED--CPUUsage.jpg
        68 kB
        Uma Maheswara Rao G
      3. HDFS-2553.patch
        1 kB
        Uma Maheswara Rao G

        Activity

        Todd Lipcon created issue -
        Todd Lipcon added a comment -

        this is a kind of stupid bug that's easy to repro:

        • start a DN on an empty file system
        • put one block on the DN
        • delete the block

        the scanner then gets in a loop, since this.isFirstBlockProcessed() returns false in the case that there are no blocks in the scanner. Putting a block back in the DN fixes it.

        Uma Maheswara Rao G added a comment -

        When i am debugging HDFS-1765, i found that TestReplication also consuming 100% CPU usage.
        The cause for that also the same.

        Looks, If cluster doesn't contains any blocks can trigger this issue.

        I feel the fix could be that, we need to check (blockInfoSet.size() > 0 && !(this.isFirstBlockProcessed())), instaed of just checking isFirstBlockProcessed().

        Uma Maheswara Rao G made changes -
        Field Original Value New Value
        Attachment HDFS-2553.patch [ 12505985 ]
        Uma Maheswara Rao G made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12505985/HDFS-2553.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1630//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1630//console

        This message is automatically generated.

        Uma Maheswara Rao G made changes -
        Attachment CPUUsage.jpg [ 12505989 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12505989/CPUUsage.jpg
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1632//console

        This message is automatically generated.

        Uma Maheswara Rao G added a comment -

        Todd, can you pls take a look on this issue once here.
        In my eclipse, many times it is triggering(Especially for TestReplication) and getting very slow down.

        Thanks
        Uma

        Todd Lipcon added a comment -

        Hey Uma, sorry I missed the patch upload before. One nit:

        -            || (!(this.isFirstBlockProcessed()))) {
        +            || (blockInfoSet.size() > 0 && !(this.isFirstBlockProcessed()))) {
        

        can you use !blockInfoSet.isEmpty() instead of checking size()? Should be faster for many collection types.

        Uma Maheswara Rao G made changes -
        Attachment HDFS-2553.patch [ 12506821 ]
        Uma Maheswara Rao G made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Uma Maheswara Rao G made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Assignee Uma Maheswara Rao G [ umamaheswararao ]
        Uma Maheswara Rao G added a comment -

        Hi Todd,

        Thanks for the review!
        Updated the patch!
        changed to (!blockInfoSet.isEmpty() && !(this.isFirstBlockProcessed()))) {
        Also retained the isEmpty condition in isFirstBlockProcessed because previous(above) check was not there in synchronization. So, there is a chance that block can be removed when just entering into isFirstBlockProcessed.

        Thanks
        Uma

        Uma Maheswara Rao G made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Uma Maheswara Rao G made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Uma Maheswara Rao G added a comment -

        Todd, can you please take a look.

        Uma Maheswara Rao G made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Uma Maheswara Rao G made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Todd Lipcon added a comment -

        +1 pending a hudson run... I'll trigger one now.

        Uma Maheswara Rao G added a comment -

        Thanks a lot, Todd for the review.
        Looks Jenkins has some issue?, last build did not run successfully.

        Uma Maheswara Rao G made changes -
        Attachment HDFS-2553.patch [ 12506821 ]
        Uma Maheswara Rao G added a comment -

        Attached the same patch again to trigger the Jenkins

        Uma Maheswara Rao G made changes -
        Attachment HDFS-2553.patch [ 12507782 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12507782/HDFS-2553.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javadoc. The javadoc tool appears to have generated 90 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        -1 findbugs. The patch appears to cause Findbugs (version 1.3.9) to fail.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hdfs.server.datanode.TestDataNodeMultipleRegistrations

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1721//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1721//console

        This message is automatically generated.

        Uma Maheswara Rao G added a comment -

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hdfs.server.datanode.TestDataNodeMultipleRegistrations

        Test failure is unrelated to this patch. Filed separate JIRA for it HDFS-2700

        Uma Maheswara Rao G made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Todd Lipcon added a comment -

        Committed to trunk and 23. Thanks, Uma!

        Todd Lipcon made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Target Version/s 0.23.1, 0.24.0 [ 12318885, 12317653 ] 0.24.0, 0.23.1 [ 12317653, 12318885 ]
        Fix Version/s 0.24.0 [ 12317653 ]
        Fix Version/s 0.23.1 [ 12318885 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #293 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/293/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220316
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1523 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1523/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220317
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #304 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/304/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220316
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1450 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1450/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220317
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1473 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1473/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220317
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #315 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/315/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220316
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #898 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/898/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220317
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #111 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/111/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220316
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #131 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/131/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220316
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #931 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/931/)
        HDFS-2553. Fix BlockPoolSliceScanner spinning in a tight loop. Contributed by Uma Maheswara Rao G.

        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1220317
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BlockPoolSliceScanner.java
        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Uma Maheswara Rao G
            Reporter:
            Todd Lipcon
          • Votes:
            0 Vote for this issue
            Watchers:
            12 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development