Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2322

the build fails in Windows because commons-daemon TAR cannot be fetched

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0, 0.24.0
    • Fix Version/s: 0.23.0, 0.24.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      For windows there is no commons-daemon TAR but a ZIP, plus the name follows a different convention.

      1. HDFS-2322v1.patch
        1.0 kB
        Alejandro Abdelnur

        Issue Links

          Activity

          Alejandro Abdelnur added a comment -

          As native stuff is not supported on windows, we should just skip the downloading of the commons-daemons TAR

          Uma Maheswara Rao G added a comment -

          Duplicate of HDFS-2321

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12493640/HDFS-2322v1.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hdfs.TestDfsOverAvroRpc
          org.apache.hadoop.hdfs.server.blockmanagement.TestHost2NodesMap
          org.apache.hadoop.hdfs.server.datanode.TestReplicasMap

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1224//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/1224//artifact/trunk/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1224//console

          This message is automatically generated.

          Uma Maheswara Rao G added a comment -

          Hi Alejandro,

          Thanks for the patch!
          If we skip downloading itself, then how jsvc file will be copied to release?

          Thanks
          Uma

          Alejandro Abdelnur added a comment -

          For Windows it is not, AFAIK none of the native code works on windows

          Uma Maheswara Rao G added a comment -

          I got your point.
          Actually our build machines are in windows and we will make use of that builds normally in linux to run our clusters.
          in this case, this will create problem right? we are mandating that builds also should happen in target OS. am i missing something here?

          Alejandro Abdelnur added a comment -

          well, you won't have any of the native code, thus you'll be running the cluster with reduced functionality. But it depends if this is an issue for your one, if not you are good.

          Alejandro Abdelnur added a comment -

          patch still applies cleanly

          Aaron T. Myers added a comment -

          +1, the patch looks good to me. I ran `mvn -DskipTests clean package' and verified that without this patch the HDFS build fails on Windows in cygwin, but with the patch the HDFS build succeeds just fine.

          The MR build still fails with some error about saveVersion.sh not working, but that's not the subject of this JIRA.

          Alejandro, you owe me big.

          Alejandro Abdelnur added a comment -

          Thanks ATM, yes I do. Still I won't rename my son to Aaron.

          Alejandro Abdelnur added a comment -

          committed to trunk, in a few days it will be committed to 0.23 in a combo with other maven related patches.

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1036 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1036/)
          HDFS-2322. the build fails in Windows because commons-daemon TAR cannot be fetched. (tucu)

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1180094
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1114 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1114/)
          HDFS-2322. the build fails in Windows because commons-daemon TAR cannot be fetched. (tucu)

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1180094
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1055 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1055/)
          HDFS-2322. the build fails in Windows because commons-daemon TAR cannot be fetched. (tucu)

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1180094
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #824 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/824/)
          HDFS-2322. the build fails in Windows because commons-daemon TAR cannot be fetched. (tucu)

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1180094
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #854 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/854/)
          HDFS-2322. the build fails in Windows because commons-daemon TAR cannot be fetched. (tucu)

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1180094
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #99 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/99/)
          Merge -r 1180093:1180094 from trunk to branch. FIXES: HDFS-2322

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190582
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #99 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/99/)
          Merge -r 1180093:1180094 from trunk to branch. FIXES: HDFS-2322

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190582
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #103 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/103/)
          Merge -r 1180093:1180094 from trunk to branch. FIXES: HDFS-2322

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190582
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #54 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/54/)
          Merge -r 1180093:1180094 from trunk to branch. FIXES: HDFS-2322

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190582
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #72 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/72/)
          Merge -r 1180093:1180094 from trunk to branch. FIXES: HDFS-2322

          tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190582
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/pom.xml

            People

            • Assignee:
              Alejandro Abdelnur
              Reporter:
              Alejandro Abdelnur
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development