Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.0
    • Component/s: None
    • Labels:
      None

      Description

      Apparently we had something like this in build.xml:

      <property name="jsvc.location" value="http://archive.apache.org/dist/commons/daemon/binaries/1.0.2/linux/commons-daemon-1.0.2-bin-linux-i386.tar.gz" />

      Also, when I manually add in jsvc binary I get this error:

      25/08/2011 23:47:18 29805 jsvc.exec error: Cannot find daemon loader org/apache/commons/daemon/support/DaemonLoader
      25/08/2011 23:47:18 29778 jsvc.exec error: Service exit with a return value of 1
      
      1. HDFS-2289v1.patch
        4 kB
        Alejandro Abdelnur
      2. HDFS-2289v2.patch
        4 kB
        Alejandro Abdelnur
      3. HDFS-2289v3.patch
        5 kB
        Arun C Murthy
      4. HDFS-2289v4.patch
        4 kB
        Alejandro Abdelnur
      5. HDFS-2289v5.patch
        5 kB
        Arun C Murthy

        Issue Links

          Activity

          Arun C Murthy added a comment -

          Alejandro kindly volunteered to look into this, thanks!

          Here is relevant code from 0.20.2xx build.xml:

            <property name="jsvc.build.dir" value="${build.dir}/jsvc" />
            <property name="jsvc.install.dir" value="${dist.dir}/libexec" />
            <property name="jsvc.location" value="http://archive.apache.org/dist/commons/daemon/binaries/1.0.2/linux/commons-daemon-1.0.2-bin-linux-i386.tar.gz" />
            <property name="jsvc.dest.name" value="jsvc.tar.gz" />
          
            <target name="jsvc" >
              <mkdir dir="${jsvc.build.dir}" />
              <get src="${jsvc.location}" dest="${jsvc.build.dir}/${jsvc.dest.name}" />
          
              <untar compression="gzip" src="${jsvc.build.dir}/${jsvc.dest.name}" dest="${jsvc.build.dir}" />
          
              <copy file="${jsvc.build.dir}/jsvc" todir="${jsvc.install.dir}" verbose="true" />
              <chmod perm="ugo+x" type="file">
                <fileset file="${jsvc.install.dir}/jsvc"/>
              </chmod>
           </target>
          
          
          
          Arun C Murthy added a comment -

          Alejandro - http://archive.apache.org/dist/commons/daemon/binaries/ only has binaries upto 1.0.5 (we need to d/w jsvc from there).

          Also, I'm having trouble with commons-daemon-1.0.5 since it has an additional dependency on libpcap - not sure it's worth it. OTOH I can get everything working with 1.0.3 - can we just stick to that version?

          Alejandro Abdelnur added a comment -

          'v1' patch, works with Mac a Linux amd64 commons daemon.

          Don't have Solaris/i686/Win VMs to verify the os/arch properties to resolve the commons-daemon TAR URL.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12491780/HDFS-2289v1.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1159//console

          This message is automatically generated.

          Alejandro Abdelnur added a comment -

          'v2' patch, order of setting props for the commons daemon download changed to ensure it works correctly later when adding other platforms.

          I've tried to get it working with Windows, but the problem is that commons daemons for for windows comes only in ZIP and for Unixes comes only in TAR.GZ. This would complicate the logic and I'm not sure HDFS secure runs on windows.

          IMPORTANT:

          Another thing regarding building in Windows. The current patch will fail in Windows as the commons daemon download will fail.

          One solution is to move the commons daemon download into the native profile. Does this make sense?

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12491806/HDFS-2289v2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1161//console

          This message is automatically generated.

          Arun C Murthy added a comment -

          Thanks Alejandro, this looks reasonable for now. Testing on a secure cluster - I'll commit after.

          Arun C Murthy added a comment -

          Updated patch, 2 changes:

          1. Setup hdfs pom.xml to d/w either i686 or x86_64 versions of jsvc binaries
          2. Change bin/hdfs to use libexec/jsvc rather than bin/jsvc.

          I brought up a secure cluster and verified both work.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12491828/HDFS-2289v3.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1164//console

          This message is automatically generated.

          Roman Shaposhnik added a comment -

          Why are we not rebuilding it? It is trivial to do and generates a much cleaner builds with dependencies to system libraries (like libc) being properly accounted for.

          Alejandro Abdelnur added a comment -

          (repeating comment from IRC):

          There is a small nit, ant related. Ant does not let you change the value of a property once set, so you'd have to invert the setting of i686 and still you should add an arch="WHATEVER-i686-IS" so it can work with other Linux archs.

          @Roman, it makes sense, I was just porting the existing functionality pre-Mavenization.

          So the question is, do we do this as part of this patch, or as a follow up?

          Roman Shaposhnik added a comment -

          I can provide a follow-up patch. It is pretty trivial.

          Alejandro Abdelnur added a comment -

          'v4' inverted condition order, first attempts more specific matching (for x86_64)

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12491844/HDFS-2289v4.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1166//console

          This message is automatically generated.

          Jakob Homan added a comment -

          it's not being built because there's no guarantee that the packages will be run on the same hardware they're being built on. We originally were building it and then ran into problems where 32bit jvms were being used against packages built on 64bit machines.

          Arun C Murthy added a comment -

          Thanks Jakob. I'll commit this and we can have a follow on jira to make this part of the native build - makes sense Roman?

          Arun C Murthy added a comment -

          Fixed a minor nit - changed d/w dir to hadoop-hdfs/target/downloads since:

          1. We don't want temporal files in main director
          2. svn needs to ignore hadoop-hdfs/downloads along with git
          Arun C Murthy added a comment -

          I just committed this. Thanks Alejandro!

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #798 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/798/)
          HDFS-2289. Ensure jsvc is bundled with the HDFS distribution artifact. Contributed by Alejandro Abdelnur.

          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1162421
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • /hadoop/common/trunk/hadoop-project-dist
          • /hadoop/common/trunk/hadoop-project/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #875 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/875/)
          HDFS-2289. Ensure jsvc is bundled with the HDFS distribution artifact. Contributed by Alejandro Abdelnur.

          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1162421
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • /hadoop/common/trunk/hadoop-project-dist
          • /hadoop/common/trunk/hadoop-project/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #808 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/808/)
          HDFS-2289. Ensure jsvc is bundled with the HDFS distribution artifact. Contributed by Alejandro Abdelnur.

          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1162421
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • /hadoop/common/trunk/hadoop-project-dist
          • /hadoop/common/trunk/hadoop-project/pom.xml
          Alejandro Abdelnur added a comment -

          Arun,

          The hdfs-project/downloads was not a nit, it was on purpose. That is why it was .gitignored as well. The reason is that if it is under target, everytime you do a 'mvn clean' you'll end up downloading it. Having it outside of target and .gitignored allows you to download it only once per workspace (if working offline mode you'll want this).

          Would you mind amending the patch to the original download dir?

          Thxs.

          Alejandro

          Roman Shaposhnik added a comment -

          Arun, sure I can follow up with the patch on Mon. Couple of questions – do I need to reopen this JIRA? Will the native build patch be included in 0.23?

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #774 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/774/)
          HDFS-2289. Ensure jsvc is bundled with the HDFS distribution artifact. Contributed by Alejandro Abdelnur.

          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1162421
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • /hadoop/common/trunk/hadoop-project-dist
          • /hadoop/common/trunk/hadoop-project/pom.xml
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #799 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/799/)
          HDFS-2289. Ensure jsvc is bundled with the HDFS distribution artifact. Contributed by Alejandro Abdelnur.

          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1162421
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/pom.xml
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
          • /hadoop/common/trunk/hadoop-project-dist
          • /hadoop/common/trunk/hadoop-project/pom.xml
          Arun C Murthy added a comment -

          @Alejandro - please open another jira to fix the d/w, I still think it should be target, else we need to add svn:ignore etc., but happy to discuss. Apologies again.

          @Roman - Please open another jira and I'm happy to commit to 0.23 if there is consensus. Thanks!

          Roman Shaposhnik added a comment -

          @Arun – HDFS-2303 opened. Please comment over there.


            People

            • Assignee:
              Alejandro Abdelnur
              Reporter:
              Arun C Murthy
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development