Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 0.23.0
    • Fix Version/s: None
    • Component/s: ha, namenode
    • Labels:
      None

      Description

      Currently Namenode has NamenodeRole with roles NAMENODE, BACKUP and CHECKPOINT. NodeType has node types NAME_NODE and DATA_NODE. Merge NamenodeRole into NodeType.

        Issue Links

          Activity

          Hide
          shv Konstantin Shvachko added a comment -

          I think this an unnecessary code change, which is induced by unnecessary attempt to change current terminology.

          Show
          shv Konstantin Shvachko added a comment - I think this an unnecessary code change, which is induced by unnecessary attempt to change current terminology.
          Hide
          tlipcon Todd Lipcon added a comment -

          Suresh, are you still planning on working on this?

          Show
          tlipcon Todd Lipcon added a comment - Suresh, are you still planning on working on this?
          Hide
          sureshms Suresh Srinivas added a comment -

          Konstantin had expressed his reservation about this change. If most of you feel this is is a good idea (I feel it is), I can work on this. So post your comments.

          Show
          sureshms Suresh Srinivas added a comment - Konstantin had expressed his reservation about this change. If most of you feel this is is a good idea (I feel it is), I can work on this. So post your comments.
          Hide
          atm Aaron T. Myers added a comment -

          I'm personally in favor of the change. It's certainly not strictly necessary, but seems like a nice simplification. I don't think the current terminology is well-known to users, as these are really internal enums within HDFS.

          Show
          atm Aaron T. Myers added a comment - I'm personally in favor of the change. It's certainly not strictly necessary, but seems like a nice simplification. I don't think the current terminology is well-known to users, as these are really internal enums within HDFS.
          Hide
          szetszwo Tsz Wo Nicholas Sze added a comment -

          NodeType is used in Storage and Upgrade while NamenodeRole is used in BackupNode. It does not make sense to pass DATA_NODE to BackupNode and, similarly, it does not make sense to pass BACKUP/CHECKPOINT to Storage. Thus, it may be better to keep two enums.

          BTW, the enum names do sound confusing. How about renaming NodeType to StorageType.

          Show
          szetszwo Tsz Wo Nicholas Sze added a comment - NodeType is used in Storage and Upgrade while NamenodeRole is used in BackupNode. It does not make sense to pass DATA_NODE to BackupNode and, similarly, it does not make sense to pass BACKUP/CHECKPOINT to Storage. Thus, it may be better to keep two enums. BTW, the enum names do sound confusing. How about renaming NodeType to StorageType.
          Hide
          atm Aaron T. Myers added a comment -

          Suresh, any update on this?

          Show
          atm Aaron T. Myers added a comment - Suresh, any update on this?
          Hide
          sureshms Suresh Srinivas added a comment -

          I am closing this as "won't fix", since this requires a bit more discussion. A new jira can be created if we see the need to this later.

          Show
          sureshms Suresh Srinivas added a comment - I am closing this as "won't fix", since this requires a bit more discussion. A new jira can be created if we see the need to this later.

            People

            • Assignee:
              sureshms Suresh Srinivas
              Reporter:
              sureshms Suresh Srinivas
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development