Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.0
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Logically, datanodes should heartbeat to block manager instead of name system. Therefore, we should move datanode heartbeat handling code to BlockManager.

      1. h2108_20110804.patch
        127 kB
        Tsz Wo Nicholas Sze
      2. h2108_20110802.patch
        127 kB
        Tsz Wo Nicholas Sze
      3. h2108_20110801.patch
        117 kB
        Tsz Wo Nicholas Sze
      4. h2108_20110727b.patch
        117 kB
        Tsz Wo Nicholas Sze
      5. h2108_20110727.patch
        116 kB
        Tsz Wo Nicholas Sze

        Activity

        Tsz Wo Nicholas Sze added a comment -

        h2108_20110727.patch: 1st patch.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12487963/h2108_20110727.patch
        against trunk revision 1151344.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 66 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these core unit tests:
        org.apache.hadoop.hdfs.server.blockmanagement.TestBlocksWithNotEnoughRacks
        org.apache.hadoop.hdfs.server.blockmanagement.TestNodeCount
        org.apache.hadoop.hdfs.server.namenode.TestDeadDatanode
        org.apache.hadoop.hdfs.server.namenode.TestDecommissioningStatus
        org.apache.hadoop.hdfs.server.namenode.TestNNThroughputBenchmark
        org.apache.hadoop.hdfs.TestDatanodeReport
        org.apache.hadoop.hdfs.TestDecommission

        +1 contrib tests. The patch passed contrib unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1037//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/1037//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1037//console

        This message is automatically generated.

        Uma Maheswara Rao G added a comment -

        Hi Nicholas,

        Looks DataNodeManager is getting blockManager as null when initializing the blockManager in DataNodeManager constructor.
        I think this is because, before actually created BlokcManager object in FSNameSystem initialization, DataNodeManager is getting the BlockManager from fsNameSystem. So, at that blockManager object not created in fsNameSystem. So, it will be null.

        
          DatanodeManager(final FSNamesystem namesystem, final Configuration conf
              ) throws IOException {
            this.namesystem = namesystem;
            this.blockManager = namesystem.getBlockManager();
            System.out.println("In DatanodeManager Constructor :::::::::::::::::::::::::::::::"+this.blockManager); // Uma added this for verification
        
        

        Output of this S.O.P is :
        In DatanodeManager Constructor :::::::::::::::::::::::::::::::null

        --Thanks

        Tsz Wo Nicholas Sze added a comment -

        Hi Uma, thanks for taking a look.

        h2108_20110727b.patch: fixed DatanodeManager constructor and activate(..).

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12487989/h2108_20110727b.patch
        against trunk revision 1151592.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 66 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these core unit tests:
        org.apache.hadoop.hdfs.TestLeaseRenewer

        +1 contrib tests. The patch passed contrib unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1043//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/1043//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1043//console

        This message is automatically generated.

        Tsz Wo Nicholas Sze added a comment -

        The failure of TestLeaseRenewer is not related to this. There was somehow a mockito exception. I could not reproduce it.

        org.mockito.exceptions.misusing.UnfinishedStubbingException: 
        Unfinished stubbing detected here:
        -> at org.apache.hadoop.hdfs.TestLeaseRenewer.testThreadName(TestLeaseRenewer.java:143)
        
        E.g. thenReturn() may be missing.
        Examples of correct stubbing:
            when(mock.isOk()).thenReturn(true);
            when(mock.isOk()).thenThrow(exception);
            doThrow(exception).when(mock).someVoidMethod();
        Hints:
         1. missing thenReturn()
         2. although stubbed methods may return mocks, you cannot inline mock creation (mock()) call inside a thenReturn method (see issue 53)
        
        	at org.apache.hadoop.hdfs.TestLeaseRenewer.testThreadName(TestLeaseRenewer.java:143)
        
        Tsz Wo Nicholas Sze added a comment -

        h2108_20110801.patch: updated with trunk

        Suresh Srinivas added a comment -

        Comments:

        1. Please add class javadoc to HeartbeatManager. Also add comment (similar to Stats) on how datanodes is synchronized
        2. Why have heartbeatManager in BlockManager. Why not just DatanodeManager to removeDataNode, stop and start decommission etc.?
        3. HeartbeatManager#size(), a better method name is getLiveDataNodeCount()?
        4. Prefer adding getStats to HeartBeatManager instead of how it is done in FSNamesystem.java that synchronizes on the HeartbeatManager.
        Suresh Srinivas added a comment -

        As much as possible, we should avoid getting HeartbeatManager from the DatanodeManager.

        Tsz Wo Nicholas Sze added a comment -

        Hi Suresh, thanks for the comments.

        h2108_20110802.patch: see below.

        1, 3, 4.
        done.

        2. Why have heartbeatManager in BlockManager. Why not just DatanodeManager to removeDataNode, stop and start decommission etc.?

        Renamed BlockManager.removeDatanode(..) to removeBlocksAssociatedTo(..)
        and moved decommission related methods to DatanodeManager.

        > As much as possible, we should avoid getting HeartbeatManager from the DatanodeManager.

        Added an interface DatanodeStatistics so that HeartbeatManager can be changed from public to package private.

        Tsz Wo Nicholas Sze added a comment -
             [exec] +1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 66 new or modified tests.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.
             [exec] 
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
             [exec] 
             [exec]     +1 system test framework.  The patch passed system test framework compile.
        
        Tsz Wo Nicholas Sze added a comment -

        Passed all unit tests except TestHDFSTrash and TestLargeBlock. These two tests always fail in my machine with/without the patch.

        Suresh Srinivas added a comment -

        Really minor comment. You are free to do this or not: Instead of long[] a, can you call it long[] stats.

        Other than that +1 for the patch.

        Tsz Wo Nicholas Sze added a comment -

        h2108_20110804.patch: renamed the local variable.

        Tsz Wo Nicholas Sze added a comment -

        I have committed this.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #738 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/738/)
        HDFS-2108. Move datanode heartbeat handling from namenode package to blockmanagement package.

        szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1154042
        Files :

        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
        • /hadoop/common/trunk/hdfs/CHANGES.txt
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestNodeCount.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/HeartbeatManager.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestNodeCount.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestBlocksWithNotEnoughRacks.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/DecommissionManager.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeStatistics.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/BlockManagerTestUtil.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestComputeInvalidateWork.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/NNThroughputBenchmark.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestHeartbeatHandling.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/NamenodeJspHelper.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestNamenodeCapacityReport.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/TestMissingBlocksAlert.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockPlacementPolicyDefault.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestOverReplicatedBlocks.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestOverReplicatedBlocks.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #812 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/812/)
        HDFS-2108. Move datanode heartbeat handling from namenode package to blockmanagement package.

        szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1154042
        Files :

        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
        • /hadoop/common/trunk/hdfs/CHANGES.txt
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestNodeCount.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/HeartbeatManager.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestNodeCount.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestBlocksWithNotEnoughRacks.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/DecommissionManager.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeStatistics.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/BlockManagerTestUtil.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestComputeInvalidateWork.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/NNThroughputBenchmark.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestHeartbeatHandling.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/NamenodeJspHelper.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestNamenodeCapacityReport.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/TestMissingBlocksAlert.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockPlacementPolicyDefault.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestOverReplicatedBlocks.java
        • /hadoop/common/trunk/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/server/blockmanagement/TestOverReplicatedBlocks.java
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java

          People

          • Assignee:
            Tsz Wo Nicholas Sze
            Reporter:
            Tsz Wo Nicholas Sze
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development