Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1924

Block information displayed in UI is incorrect

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 0.20-append
    • Fix Version/s: 0.20-append
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Tags:
      namenode UI

      Description

      Problem statement
      ================
      Deleted blocks are not removed from the blockmap.
      Solution
      =======
      Whenever delete is called the block entry must be removed from the block map and also move it to invalidates.

      1. HDFS-1924.patch
        6 kB
        ramkrishna.s.vasudevan

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          8d 9h 22m 1 ramkrishna.s.vasudevan 20/May/11 16:28
          Patch Available Patch Available Resolved Resolved
          187d 14h 46m 1 Uma Maheswara Rao G 24/Nov/11 06:14
          Uma Maheswara Rao G made changes -
          Link This issue duplicates HDFS-140 [ HDFS-140 ]
          Uma Maheswara Rao G made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Uma Maheswara Rao G added a comment -

          After the analysis, the root cause for this issue should be HDFS-140, So, closing this as duplicate.

          Uma Maheswara Rao G made changes -
          Assignee Uma Maheswara Rao G [ umamaheswararao ]
          ramkrishna.s.vasudevan added a comment -

          Thanks Todd for your comments.
          We have tested in our cluster in long run scenarios also.

          But i will check the HDFS-381 defect also.

          Todd Lipcon added a comment -

          This patch looks similar to HDFS-381. I'm hesitant to include it in 0.20-append since it has no serious ramifications and touches NN internals. Have you tested it on a real cluster for any length of time?

          ramkrishna.s.vasudevan added a comment -

          This patch is for 0.20-append branch

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12479916/HDFS-1924.patch
          against trunk revision 1125217.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 7 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/601//console

          This message is automatically generated.

          ramkrishna.s.vasudevan made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          ramkrishna.s.vasudevan made changes -
          Field Original Value New Value
          Attachment HDFS-1924.patch [ 12479916 ]
          ramkrishna.s.vasudevan created issue -

            People

            • Assignee:
              Uma Maheswara Rao G
              Reporter:
              ramkrishna.s.vasudevan
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development