Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1782

FSNamesystem.startFileInternal(..) throws NullPointerException

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0, 0.23.0
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      I'm observing when there is one balancer running trying to run another one results in
      "Java.lang.NullPointerException" error. I was hoping to see message "Another balancer is running.
      Exiting.... Exiting ...". This is a reproducible issue.

      Details
      ========

      1) Cluster ->elrond

      [hdfs@]$ hadoop version

      2) Run first balancer
      [hdfs]$ hdfs balancer
      1
      through XX.XX.XX.XX:1004 is succeeded.
      [hdfs@]$ hdfs balancer
      11/03/09 16:34:32 INFO balancer.Balancer: namenodes =
      java.io.IOException: java.lang.NullPointerException
      at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFileInternal(FSNamesystem.java:1400)
      at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFile(FSNamesystem.java:1284)
      at org.apache.hadoop.hdfs.server.namenode.NameNode.create(NameNode.java:779)
      at sun.reflect.GeneratedMethodAccessor46.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.hadoop.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:346)
      at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1399)
      at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1395)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAs(Subject.java:396)
      at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1094)
      at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1393)
      . Exiting ...
      Balancing took 1.366 seconds

      1. HDFS-1782.patch
        0.8 kB
        John George

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-22-branch #35 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-22-branch/35/)

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #643 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/643/)

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #582 (See https://hudson.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/582/)

        Tsz Wo Nicholas Sze added a comment -

        I have committed this. Thanks, John!

        Tsz Wo Nicholas Sze added a comment -

        +1 patch looks good.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12474821/HDFS-1782.patch
        against trunk revision 1086820.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these core unit tests:
        org.apache.hadoop.cli.TestHDFSCLI
        org.apache.hadoop.hdfs.server.datanode.TestTransferRbw
        org.apache.hadoop.hdfs.TestDFSShell
        org.apache.hadoop.hdfs.TestFileConcurrentReader

        -1 contrib tests. The patch failed contrib unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/305//testReport/
        Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/305//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/305//console

        This message is automatically generated.

        John George added a comment -

        This was caused because of a null pointer deference. The change was tested by the same person who filed this bug and it passed.

        I thought about adding a test to run multiple balancers to as part of the unit test, but the timing of balancers does not guarantee that this will always test the change that was put in. Adding a "mock" test was a possibility, but it seems to me that it requires source code change to be able to "mock" and test the particular change.

        [exec] BUILD SUCCESSFUL
        [exec] Total time: 49 seconds
        [exec]
        [exec]
        [exec]
        [exec]
        [exec] -1 overall.
        [exec]
        [exec] +1 @author. The patch does not contain any @author tags.
        [exec]
        [exec] -1 tests included. The patch doesn't appear to include any new or modified tests.
        [exec] Please justify why no new tests are needed for this patch.
        [exec] Also please list what manual steps were performed to verify this patch.
        [exec]
        [exec] +1 javadoc. The javadoc tool did not generate any warning messages.
        [exec]
        [exec] +1 javac. The applied patch does not increase the total number of javac compiler warnings.
        [exec]
        [exec] +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.
        [exec]
        [exec] +1 release audit. The applied patch does not increase the total number of release audit warnings.
        [exec]
        [exec] +1 system test framework. The patch passed system test framework compile.
        [exec]


          People

          • Assignee:
            John George
            Reporter:
            John George
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development