Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1576

TestWriteConfigurationToDFS is timing out on trunk

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Not A Problem
    • Affects Version/s: 0.22.0, 0.23.0
    • Fix Version/s: 0.22.0, 0.23.0
    • Component/s: namenode
    • Labels:
      None
    • Environment:

      OSX 10.6

      Description

      On a fresh checkout, TestWriteConfigurationToDFS, runs, errors out and then never returns, blocking all subsequent tests. This is reproducible with -Dtestcase=

          [junit] Running org.apache.hadoop.hdfs.TestWriteConfigurationToDFS
          [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 60.023 sec
      

        Issue Links

          Activity

          Jakob Homan created issue -
          Jakob Homan made changes -
          Field Original Value New Value
          Link This issue is part of HADOOP-7082 [ HADOOP-7082 ]
          Jakob Homan made changes -
          Priority Major [ 3 ] Blocker [ 1 ]
          Jakob Homan added a comment -

          This looks like it may be an Ivy issue:

          [ivy:resolve] downloading https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-common-test/0.23.0-SNAPSHOT/hadoop-common-test-0.23.0-20101226.201
          217-25.jar ...
          [ivy:resolve] ..
          

          The common jar that's being pulled is from before the fix was committed and so the regression test is triggering the event.

          Jakob Homan added a comment -

          A new version of the commons jar has been pushed to Ivy. This has resolved itself. Closing the issue.

          Of concern though is when the test fails in this way it does just fail, it locks up and stops any more tests from proceeding. This is suboptimal, but since it's unlikely to be an issue again, it's probably not worth focusing on now.

          Jakob Homan made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Not A Problem [ 8 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          21h 44m 1 Jakob Homan 11/Jan/11 21:28

            People

            • Assignee:
              Unassigned
              Reporter:
              Jakob Homan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development