Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.22.0, 0.23.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      There are a bunch of warnings besides DeprecatedUTF8, HDFS-1512 and two warnings caused by a Java bug (http://bugs.sun.com/view_bug.do?bug_id=646014) that we can fix.

        Activity

        Eli Collins added a comment -

        Patch attached. Fixes almost all the warnings.

        Eli Collins added a comment -

        This is a pretty simple patch, if no one objects I'll commit it.

        Konstantin Boudnik added a comment -

        +1 patch looks good. Please run the usual validation.

        Eli Collins added a comment -

        Thanks Cos.

             [exec] 
             [exec] -1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 15 new or modified tests.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.
             [exec] 
             [exec]     -1 release audit.  The applied patch generated 103 release audit warnings (more than the trunk's current 98 warnings).
             [exec] 
             [exec]     +1 system test framework.  The patch passed system test framework compile.
             [exec] 
        

        The rat report failure is due to the following being in the report that's run with my patch vs the default one (as files that don't contain a license). I'm not sure why the default run doesn't include these, this patch doesn't modify them.

        [rat:report]  !????? /home/eli/src/hdfs-trunk/build/hadoop-hdfs-PATCH-hdfs-1513-1.patch/conf/core-site.xml
        [rat:report]  !????? /home/eli/src/hdfs-trunk/build/hadoop-hdfs-PATCH-hdfs-1513-1.patch/conf/hadoop-env.sh
        [rat:report]  !????? /home/eli/src/hdfs-trunk/build/hadoop-hdfs-PATCH-hdfs-1513-1.patch/conf/hadoop-policy.xml
        [rat:report]  !????? /home/eli/src/hdfs-trunk/build/hadoop-hdfs-PATCH-hdfs-1513-1.patch/conf/masters
        [rat:report]  !????? /home/eli/src/hdfs-trunk/build/hadoop-hdfs-PATCH-hdfs-1513-1.patch/conf/slaves
        
        Eli Collins added a comment -

        I've committed this.


          People

          • Assignee:
            Eli Collins
            Reporter:
            Eli Collins
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development