Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-14281 Dynamometer Phase 2
  3. HDFS-14638

[Dynamometer] Fix scripts to refer to current build structure

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: namenode, test
    • Labels:
      None

      Description

      The scripts within the Dynamometer build dirs all refer to the old distribution structure with a single bin directory and a single lib directory. We need to update them to refer to the Hadoop-standard layout.

      Also as pointed out by kevin su:

      Due to dynamometer rename to hadoop-dynamometer in hadoop-tools

      but we still use old name of jar inside the scripts

      "$hadoop_cmd" jar "${script_pwd}"/lib/dynamometer-infra-*.jar org.apache.hadoop.tools.dynamometer.Client "$@"
      

      We should rename these jar inside the scripts

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tasanuma Takanobu Asanuma
                Reporter:
                xkrogen Erik Krogen
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: