Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1420

Clover build doesn't generate per-test coverage

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.1, 0.22.0
    • Fix Version/s: 0.21.1
    • Component/s: build, test
    • Labels:
      None
    • Release Note:
      This fix requires that test coverage is running under Clover 3.0+

      Description

      Because of the way the structure of Hadoop's builds is done Clover can't properly detect test classes among the sources. As the result clover reports are incomplete and do not provide viral per-test coverage info.

      1. HDFS-1420.patch
        0.6 kB
        Konstantin Boudnik
      2. HDFS-1420.patch
        0.5 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #406 (See https://hudson.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/406/)

          Konstantin Boudnik made changes -
          Affects Version/s 0.20.3 [ 12314814 ]
          Konstantin Boudnik made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Release Note This fix requires that test coverage is running under Clover 3.0+
          Fix Version/s 0.21.1 [ 12315271 ]
          Resolution Fixed [ 1 ]
          Konstantin Boudnik added a comment -

          The fix is exactly the same as for HADOOP-6971. Thus, no separate review seems needed. I have ran the test with Clover on and see that the problem is gone.

          Konstantin Boudnik made changes -
          Attachment HDFS-1420.patch [ 12455520 ]
          Konstantin Boudnik made changes -
          Attachment HDFS-1420.patch [ 12455516 ]
          Konstantin Boudnik made changes -
          Summary CLONE -Clover build doesn't generate per-test coverage Clover build doesn't generate per-test coverage
          Konstantin Boudnik made changes -
          Project Hadoop Common [ 12310240 ] Hadoop HDFS [ 12310942 ]
          Key HADOOP-6972 HDFS-1420
          Affects Version/s 0.20.3 [ 12314814 ]
          Affects Version/s 0.21.1 [ 12315271 ]
          Affects Version/s 0.22.0 [ 12314241 ]
          Affects Version/s 0.22.0 [ 12314296 ]
          Affects Version/s 0.20.3 [ 12314812 ]
          Affects Version/s 0.21.1 [ 12315270 ]
          Component/s build [ 12312925 ]
          Component/s test [ 12312916 ]
          Component/s test [ 12311440 ]
          Component/s build [ 12311543 ]
          Konstantin Boudnik made changes -
          Field Original Value New Value
          Link This issue is a clone of HADOOP-6971 [ HADOOP-6971 ]
          Konstantin Boudnik created issue -

            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development