Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1344

trunk HDFS build breakage with build.properties (resolvers=internal)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
      None
    • Environment:

      Linux x86-32

      Description

      The documented checkout and build approach (http://wiki.apache.org/hadoop/GitAndHadoop) fails on hadoop-hdfs, apparently because it is incapable of finding the internally built hadoop-common (~/.ivy2/cache/org.apache.hadoop/hadoop-common/jars/hadoop-common-$

      {version}

      .jar).

      Moving build.properties aside and running "ant mvn-install" mostly works, but only because it downloads the SNAPSHOT jar from Apache Hudson or something (apparently--at any rate, I never built hadoop-common without build.properties on this machine, yet hadoop-hdfs's basic build worked). The HDFS build still fails on fault-injection, but I'll file a separate JIRA for that.

        Activity

        Greg Roelofs created issue -
        Greg Roelofs added a comment -

        The separate JIRA was HDFS-1345, but it turned out to be a duplicate of HDFS-1157.

        Allen Wittenauer added a comment -

        Likely stale.

        Allen Wittenauer made changes -
        Field Original Value New Value
        Resolution Incomplete [ 4 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1443d 1m 1 Allen Wittenauer 31/Jul/14 00:32

          People

          • Assignee:
            Unassigned
            Reporter:
            Greg Roelofs
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development