Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-12447

Rename AddECPolicyResponse to AddErasureCodingPolicyResponse

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 3.0.0-beta1
    • None
    • Incompatible change
    • HdfsAdmin#addErasureCodingPolicies now returns an AddErasureCodingPolicyResponse[] rather than AddECPolicyResponse[]. The corresponding RPC definition and PB message have also been renamed.

    Description

      As a follow on to handle some issues discussed in HDFS-12395, this is to majorly refactor addErasureCodingPoliy API, change AddECPolicyResponse => AddErasureCodingPolicyResponse

      Attachments

        1. HDFS-12447.004.patch
          31 kB
          Sammi Chen
        2. HDFS-12447.003.patch
          31 kB
          Kai Zheng
        3. HDFS-12447.002.patch
          32 kB
          Sammi Chen
        4. HDFS-12447.001.patch
          31 kB
          Sammi Chen

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Sammi Sammi Chen
            Sammi Sammi Chen
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment