Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-12447

Rename AddECPolicyResponse to AddErasureCodingPolicyResponse

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-beta1
    • Component/s: None
    • Hadoop Flags:
      Incompatible change
    • Release Note:
      HdfsAdmin#addErasureCodingPolicies now returns an AddErasureCodingPolicyResponse[] rather than AddECPolicyResponse[]. The corresponding RPC definition and PB message have also been renamed.

      Description

      As a follow on to handle some issues discussed in HDFS-12395, this is to majorly refactor addErasureCodingPoliy API, change AddECPolicyResponse => AddErasureCodingPolicyResponse

        Attachments

        1. HDFS-12447.004.patch
          31 kB
          SammiChen
        2. HDFS-12447.003.patch
          31 kB
          Kai Zheng
        3. HDFS-12447.002.patch
          32 kB
          SammiChen
        4. HDFS-12447.001.patch
          31 kB
          SammiChen

          Activity

            People

            • Assignee:
              Sammi SammiChen
              Reporter:
              Sammi SammiChen
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: