Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1193

-mvn-system-deploy target is broken which inturn fails the mvn-deploy task leading to unstable mapreduce build.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      -mvn-system-deploy:
      [artifact:install-provider] Installing provider: org.apache.maven.wagon:wagon-http:jar:1.0-beta-2:runtime
      [artifact:deploy] Deploying to https://repository.apache.org/content/repositories/snapshots
      [artifact:deploy] [INFO] Retrieving previous build number from apache.snapshots.https
      [artifact:deploy] Uploading: org/apache/hadoop/hadoop-hdfs-instrumented/0.22.0-SNAPSHOT/hadoop-hdfs-instrumented-0.22.0-20100608.071421-8.jar to apache.snapshots.https
      [artifact:deploy] Uploaded 990K
      [artifact:deploy] [INFO] Retrieving previous metadata from apache.snapshots.https
      [artifact:deploy] [INFO] Uploading repository metadata for: 'snapshot org.apache.hadoop:hadoop-hdfs-instrumented:0.22.0-SNAPSHOT'
      [artifact:deploy] [INFO] Retrieving previous metadata from apache.snapshots.https
      [artifact:deploy] [INFO] Uploading repository metadata for: 'artifact org.apache.hadoop:hadoop-hdfs-instrumented'
      [artifact:deploy] [INFO] Uploading project information for hadoop-hdfs-instrumented 0.22.0-20100608.071421-8
      [artifact:deploy] [INFO] Retrieving previous build number from apache.snapshots.https
      [artifact:deploy] Uploading: org/apache/hadoop/hadoop-hdfs-instrumented/0.22.0-SNAPSHOT/hadoop-hdfs-instrumented-0.22.0-20100608.071421-8-sources.jar to apache.snapshots.https
      [artifact:deploy] Uploaded 610K
      [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
      [artifact:deploy] Diagnosis:
      [artifact:deploy]
      [artifact:deploy] Invalid reference: 'hadoop.hdfs.instrumented.test'

      1. hdfs-1193.patch
        0.9 kB
        Giridharan Kesavan

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #298 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/298/)
        HDFS-1193. -mvn-system-deploy target is broken which inturn fails the
        mvn-deploy task leading to unstable mapreduce build. Contributed by Giridharan
        Kesavan.

        Konstantin Boudnik added a comment -

        I have just committed this. Thanks Giri.

        Konstantin Boudnik added a comment -

        core test problem is known intermittent issue (HDFS-733)
        contrib test is TestHdfsProxy failing for month+

        So, I'm going to commit this.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12446584/hdfs-1193.patch
        against trunk revision 951555.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/401/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/401/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/401/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/401/console

        This message is automatically generated.

        Konstantin Boudnik added a comment -

        Let's verify just in case.

        Konstantin Boudnik added a comment -

        This patch has to be applied back to branch-0.21 as well because the issue is present there too.
        +1 patch looks good. Thanks for catching it Giri!

        Giridharan Kesavan added a comment -

        added the issue to the right component and version

        Giridharan Kesavan added a comment -

        This patch fixes the -mvn-system-deploy task and hence the trunk builds.

        Giridharan Kesavan added a comment -

        Trunk hdfs commit builds are broken in the last 6 days b'coz of this.

        http://hudson.zones.apache.org/hudson/view/Hdfs/job/Hadoop-Hdfs-trunk-Commit


          People

          • Assignee:
            Giridharan Kesavan
            Reporter:
            Giridharan Kesavan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development