Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-11405

Rename "erasurecode" CLI subcommand to "ec"

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha4
    • Component/s: erasure-coding
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Incompatible change
    • Release Note:
      The "hdfs erasurecode" CLI command has been renamed to "hdfs ec" for ease-of-use.

      Description

      Right now the erasure coding CLI subcommand is "erasurecode". I think it'd be nice to shorten this to just "ec".

      We've shortened things like "memory caching" to "cache" or "at rest encryption" to "crypto" for ease of use, this is in the same style.

      This would also require doc updates.

        Attachments

        1. HDFS-11405.01.patch
          4 kB
          Manoj Govindassamy

          Activity

            People

            • Assignee:
              manojg Manoj Govindassamy
              Reporter:
              andrew.wang Andrew Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: