Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1061

Memory footprint optimization for INodeFile object.

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Incompatible change, Reviewed

      Description

      I am proposing a footprint optimization to merge blockReplication and preferredBlockSize fields into one 'long header' field in INodeFile class. This saves 8 bytes per INodeFile object on a 64 bit JVM. This memory optimization is transparent and changes are very minimal.

      1. HDFS-1061-rel20.patch
        9 kB
        Bharath Mundlapudi
      2. HDFS-1061-3.patch
        10 kB
        Bharath Mundlapudi
      3. HDFS-1061-2.patch
        10 kB
        Bharath Mundlapudi
      4. HDFS-1061-1.patch
        9 kB
        Bharath Mundlapudi
      5. HDFS-1061.patch
        5 kB
        Bharath Mundlapudi

        Activity

        Bharath Mundlapudi created issue -
        Bharath Mundlapudi added a comment -

        INodeFile objects are proportional to the number of files created. By eliminating short data field, we get 8 bytes of saving due to byte code alignment on a 64bit JVM. We can have 40 bits for preferred block Size and 24 bit for block replication. We probably don't need 24 bit for replication. In future, we could use these extra bits for storing some other meta data without creating new data types in this memory structure.

        Hong Tang added a comment -

        @bharath, what is the average size of an INodeFile object currently?

        Bharath Mundlapudi added a comment -

        At present, The shallow size of INodeFile object consumes 80 bytes on a 64bit JVM. There are couple of objects in NameNode which are in critical path for scalability of number of files. One of them is INodeFile object. Also, INodeFile objects are long lived and placed in tenure generation and as these objects grow in number can put more pressure on Garbage Collector. So reducing the size of INodeFile object has good number of benefits.

        dhruba borthakur added a comment -

        Can you describe this change as a percentage-improvement over the current size of INodeFile?

        Bharath Mundlapudi added a comment -

        10% saving from the current INodeFile.

        Tsz Wo Nicholas Sze added a comment -

        We probably could safely assume that preferredBlockSize is a power of 2. In such case, only the exponents need be stored. A 6-bit integer is good enough.

        Bharath Mundlapudi added a comment -

        Storing exponents is a good suggestion and i thought about this but didn't suggest for the following reasons
        1. storing and retrieving need more cpu cycles for the computation.
        2. didn't want to assume power of n.
        3. unless we are saving another 8 bytes for byte alignment or else even with 1 byte we will be forced to use 8 byte on 64-bit JVM.
        4. I believe, ext3 and ext4 file systems uses 32 bit and 64 bit block addressing respectively so i thought 40 bit (1TB) probably good enough for HDFS block size. Note that for my proposal, we could go for 48 bit preferred block size and 16 bit replication which may not be required and also won't give any extra bits for storing meta data in future if we want to.

        Bharath Mundlapudi added a comment -

        A small correction and additional note for my comment above, ext4 uses 48 bit block addressing. I didn't want to assume power of n due to backward compatibility reasons since we don't know how hadoop customers are using preferred block size so far.

        dhruba borthakur added a comment -

        It appears that this proposal is:

        48 bits for preferredBlocksize (u.e. max block size is 512 TB)
        16 bits for block replication (i.e. max of 64000 replicas of a block)

        This scheme should be backward compatible, no existing installations should have a problem with these settings. Seems like a good proposal to me.

        Bharath Mundlapudi made changes -
        Field Original Value New Value
        Assignee Bharath Mundlapudi [ bharathm ]
        Bharath Mundlapudi made changes -
        Attachment HDFS-1061.patch [ 12439929 ]
        Bharath Mundlapudi added a comment -

        Attached the patch for this optimization

        Bharath Mundlapudi made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12439929/HDFS-1061.patch
        against trunk revision 927999.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        -1 javac. The patch appears to cause tar ant target to fail.

        -1 findbugs. The patch appears to cause Findbugs to fail.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/286/testReport/
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/286/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/286/console

        This message is automatically generated.

        dhruba borthakur added a comment -

        we should try to get this into the impending 0.21 re-release. Can we fix the cause why HadoopQA did a -1 to this one?

        Eli Collins added a comment -

        Patch lgtm. I wonder if we should limit the number of bits for replicas - 64k seems is overkill and this would leave space for an additional field. Perhaps we just cross that bridge when we come to it.

        Looking at the console output it looks like the failures are due to a maven issue. Let's just cancel and resubmit the patch. It applies to trunk on my local tree and ant test-core is running ok so far.

        Hong Tang made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Hong Tang added a comment -

        Retry hudson per Eli's suggestion.

        Hong Tang made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12439929/HDFS-1061.patch
        against trunk revision 934196.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/315/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/315/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/315/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/315/console

        This message is automatically generated.

        Jakob Homan added a comment -

        The patch looks good, but Hudson is right - we should have some basic sanity unit tests here, if for no other reason, than to catch any mistakes that may be introduced later that don't jive with the assumptions made in the patch. The new logic in INodeFile is easily testable. I'll +1 and commit once some basic unit tests are included.

        Jakob Homan added a comment -

        Canceling patch pending new unit test.

        Jakob Homan made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Bharath Mundlapudi added a comment -

        Attaching the patch with the unit tests.

        Bharath Mundlapudi made changes -
        Attachment HDFS-1061.patch.1 [ 12443666 ]
        Bharath Mundlapudi made changes -
        Attachment HDFS-1061.patch.1 [ 12443666 ]
        Bharath Mundlapudi made changes -
        Attachment HDFS-1061-1.patch [ 12443667 ]
        Bharath Mundlapudi added a comment -

        Attached the patch with unit tests

        Bharath Mundlapudi made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12443667/HDFS-1061-1.patch
        against trunk revision 939918.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        -1 javac. The applied patch generated 23 javac compiler warnings (more than the trunk's current 22 warnings).

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/343/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/343/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/343/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/343/console

        This message is automatically generated.

        Bharath Mundlapudi made changes -
        Attachment HDFS-1061-1.patch [ 12443667 ]
        Bharath Mundlapudi made changes -
        Attachment HDFS-1061-1.patch [ 12443718 ]
        Bharath Mundlapudi made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Bharath Mundlapudi made changes -
        Attachment HDFS-1061-2.patch [ 12443783 ]
        Bharath Mundlapudi added a comment -

        Fixed the warning and indented the code.

        Bharath Mundlapudi made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12443783/HDFS-1061-2.patch
        against trunk revision 939918.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/170/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/170/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/170/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/170/console

        This message is automatically generated.

        Jakob Homan added a comment -

        Thanks for the tests Bharath.

        • For number of replicas does a checking for less than 0 make sense? Should it be <= 0. A replica count of 0 seems odd...
        • For the tests that are expected to throw an exception, it's not necessary to include the always-fails assert. Junit will take care of this. (Also, Junit provides the fail(msg) method, which is equivalent to assertTrue(false)).

        Other than that looks good.

        Bharath Mundlapudi added a comment -

        Thanks for the review, Jakob.

        Some thoughts on your comments:

        1. Yes, Zero replica seems odd but didn't want to break the old semantics since earlier versions was allowing 0 and < 0 values. Atleast its clear NOT accept < 0 values.
        2. The reason i put always-fail assert because the test-case always throws an exception.

        Let me know if you want me to add/change something.

        Bharath Mundlapudi made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Bharath Mundlapudi made changes -
        Attachment HDFS-1061-3.patch [ 12444153 ]
        Bharath Mundlapudi added a comment -

        Attached the new patch.

        Bharath Mundlapudi made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12444153/HDFS-1061-3.patch
        against trunk revision 942863.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/173/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/173/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/173/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/173/console

        This message is automatically generated.

        Jakob Homan added a comment -

        Contrib test failure unrelated. +1. Marking as incompatible change due to more strict bounds checking.

        Jakob Homan made changes -
        Hadoop Flags [Incompatible change, Reviewed]
        Jakob Homan added a comment -

        I've just committed this. Thanks, Bharath! Resolving as fixed.

        Jakob Homan made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Bharath Mundlapudi added a comment -

        Attached the patch for release 0.20

        Bharath Mundlapudi made changes -
        Attachment HDFS-1061-rel20.patch [ 12446181 ]

          People

          • Assignee:
            Bharath Mundlapudi
            Reporter:
            Bharath Mundlapudi
          • Votes:
            0 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development