Uploaded image for project: 'Hadoop Distributed Data Store'
  1. Hadoop Distributed Data Store
  2. HDDS-995

Use final hadoop 3.2.0 dependency in Ozone

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      As of now Ozone uses the (off-tree) 3.2.1-SNAPSHOT hadoop dependency. Mainly beacause there was no recent hadoop release which includes all the required improvements for Ozone.

      Finally hadoop 3.2.0 is uploaded to the Apache Nexus repository and we can switch to use the latest release artifacts instead of snapshots.

      To use 3.2.0 hadoop-ozone/pom.xml and hadoop-hdds/pom.xml should be updated to use 3.2.0 version of the parent.

      The build can be tested with

      ./hadoop-ozone/dev-support/checks/build.sh

      ./hadoop-ozone/dev-support/checks/acceptance.sh

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sdeka Supratim Deka
                Reporter:
                elek Marton Elek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: