Details

    • Sub-task
    • Status: Resolved
    • Major
    • Resolution: Implemented
    • None
    • 1.4.0
    • ECOfflineRecovery
    • None

    Description

          • Need logging in the scm log indicating a reconstruction was started for a particular container, etc, also a log entry indicating the reconstruction is completed. currently we only have this msg in the log:

      LOG.debug("Missing indexes detected for the container {}." +
      " The missing indexes are {}", id, missingIndexes);

      Assume same goes to over replication handling as well.

          • Seems there was some out of sync when reporting number of processed containers from hdds.scm.container.replication.UnderReplicatedProcessor logging,

      Following were some sample log entries observed from scm log:

      :

      2022-08-02 17:33:11,020 INFO org.apache.hadoop.hdds.scm.container.replication.UnderReplicatedProcessor: Processed 0 under replicated containers, failed processing 0

      2022-08-02 17:33:41,021 INFO org.apache.hadoop.hdds.scm.container.replication.UnderReplicatedProcessor: Processed 0 under replicated containers, failed processing 0

      2022-08-02 17:34:11,021 INFO org.apache.hadoop.hdds.scm.container.replication.UnderReplicatedProcessor: Processed 0 under replicated containers, failed processing 0

      2022-08-02 17:34:41,021 INFO org.apache.hadoop.hdds.scm.container.replication.UnderReplicatedProcessor: Processed 0 under replicated containers, failed processing 0

      While the actual reconstruction was already done.

      Attachments

        Activity

          People

            adoroszlai Attila Doroszlai
            ghuangups George Huang
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: