HBase
  1. HBase
  2. HBASE-9558

PerformanceEvaluation is in hbase-server, and create a dependency to MiniDFSCluster

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.98.0
    • Fix Version/s: 0.98.0, 0.96.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      It's the only dependency that is not in the tests package.

      I'm not clear on how to fix it. Any idea?

      1. 9558.addendum.v1.patch
        0.9 kB
        Nicolas Liochon
      2. 9958.v1.patch
        7 kB
        Nicolas Liochon

        Activity

        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK #4541 (See https://builds.apache.org/job/HBase-TRUNK/4541/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster - addendum (nkeywal: rev 1525120)

        • /hbase/trunk/hbase-server/pom.xml
        Hudson added a comment -

        FAILURE: Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #747 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/747/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster - addendum (nkeywal: rev 1525120)

        • /hbase/trunk/hbase-server/pom.xml
        Hudson added a comment -

        FAILURE: Integrated in hbase-0.96-hadoop2 #43 (See https://builds.apache.org/job/hbase-0.96-hadoop2/43/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster - addendum (nkeywal: rev 1525121)

        • /hbase/branches/0.96/hbase-server/pom.xml
        Hudson added a comment -

        FAILURE: Integrated in hbase-0.96 #77 (See https://builds.apache.org/job/hbase-0.96/77/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster - addendum (nkeywal: rev 1525121)

        • /hbase/branches/0.96/hbase-server/pom.xml
        Nicolas Liochon added a comment -

        Good news

        Sorry for the mess. Thanks for the alert, Ted.

        Ted Yu added a comment -

        Test suite result was good.

        Nicolas Liochon added a comment -

        Done.

        stack added a comment -

        [~liochon] +1 if works for you. Please commit so I can make next RC. Thanks boss.

        Nicolas Liochon added a comment -

        Ted Yu, are you ok with the addendum? I would like to commit it, as the build is broken on hadoop2 w/o it.

        Ted Yu added a comment -

        TestResourceFilter passes.

        Running test suite now.

        Elliott Clark added a comment -

        +1 on addendum. Makes sense.

        Nicolas Liochon added a comment -

        The addendum fixes the issue reported by Ted.

        Hudson added a comment -

        FAILURE: Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #746 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/746/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster (nkeywal: rev 1524985)

        • /hbase/trunk/hbase-hadoop2-compat/pom.xml
        • /hbase/trunk/hbase-server/pom.xml
        • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
        Nicolas Liochon added a comment -

        I'm having a look.

        Ted Yu added a comment -

        I got the following test failure based on hadoop-2 profile:

        org.apache.hadoop.hbase.rest.TestResourceFilter  Time elapsed: 0.001 sec  <<< ERROR!
        java.lang.NoClassDefFoundError: org/apache/hadoop/net/StaticMapping
                at org.apache.hadoop.hdfs.MiniDFSCluster.initMiniDFSCluster(MiniDFSCluster.java:621)
                at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:585)
                at org.apache.hadoop.hbase.HBaseTestingUtility.startMiniDFSCluster(HBaseTestingUtility.java:511)
                at org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTestingUtility.java:840)
                at org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTestingUtility.java:765)
                at org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTestingUtility.java:736)
                at org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTestingUtility.java:705)
                at org.apache.hadoop.hbase.rest.TestResourceFilter.setUpBeforeClass(TestResourceFilter.java:43)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:606)
                at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
                at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
                at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
                at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
                at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
                at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
                at org.junit.runners.Suite.runChild(Suite.java:127)
                at org.junit.runners.Suite.runChild(Suite.java:26)
                at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
                at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
                at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
                at java.util.concurrent.FutureTask.run(FutureTask.java:166)
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
                at java.lang.Thread.run(Thread.java:724)
        Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.net.StaticMapping
                at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
                at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
                at java.security.AccessController.doPrivileged(Native Method)
                at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
                at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
                at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
                at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        
        Hudson added a comment -

        FAILURE: Integrated in hbase-0.96-hadoop2 #42 (See https://builds.apache.org/job/hbase-0.96-hadoop2/42/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster (nkeywal: rev 1524986)

        • /hbase/branches/0.96/hbase-hadoop2-compat/pom.xml
        • /hbase/branches/0.96/hbase-server/pom.xml
        • /hbase/branches/0.96/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
        Hudson added a comment -

        FAILURE: Integrated in hbase-0.96 #75 (See https://builds.apache.org/job/hbase-0.96/75/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster (nkeywal: rev 1524986)

        • /hbase/branches/0.96/hbase-hadoop2-compat/pom.xml
        • /hbase/branches/0.96/hbase-server/pom.xml
        • /hbase/branches/0.96/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK #4538 (See https://builds.apache.org/job/HBase-TRUNK/4538/)
        HBASE-9558 PerformanceEvaluation is in hbase-server, and creates a dependency to MiniDFSCluster (nkeywal: rev 1524985)

        • /hbase/trunk/hbase-hadoop2-compat/pom.xml
        • /hbase/trunk/hbase-server/pom.xml
        • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
        Nicolas Liochon added a comment -

        Committed, thanks for the feedback and the reviews!

        Jean-Marc Spaggiari added a comment -

        +1 for me too. I don't use this option with PE. I run PE against pseudo-distributed and soon (a week or 2 from now) on a fully dedicate 4 nodes cluster...

        Regarding the failing test, I don't really think it's related.

        stack added a comment -

        +1

        Is test failure related?

        Nick Dimiduk added a comment -

        +1

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12604009/9958.v1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.snapshot.TestFlushSnapshotFromClient

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7299//console

        This message is automatically generated.

        Nicolas Liochon added a comment -

        Ok, if nobody objects I will do that.

        stack added a comment -

        [~liochon] Just remove --minicluster. When would that option be useful? (running all inside the one jvm? That'd be ugly!)

        Nicolas Liochon added a comment -

        Or should we just remove the capability to use it with an internal mini cluster (it would still be possible to use on a local instance? Jean-Marc Spaggiari, what do you think? Do you use the mini cluster feature for the perf eval?

        Nick Dimiduk added a comment -

        Move PerfEval into the IT module?

        Nicolas Liochon added a comment -

        [INFO] org.apache.hbase:hbase-server:jar:0.97.0-SNAPSHOT
        [INFO] +- org.apache.hbase:hbase-hadoop2-compat:jar:0.97.0-SNAPSHOT:compile
        [INFO] | - org.apache.hadoop:hadoop-minicluster:jar:2.1.0-beta:compile
        [INFO] | +- org.apache.hadoop:hadoop-common:test-jar:tests:2.1.0-beta:compile
        [INFO] | +- org.apache.hadoop:hadoop-hdfs:test-jar:tests:2.1.0-beta:compile
        [INFO] | | +- commons-daemon:commons-daemon:jar:1.0.13:compile
        [INFO] | | - javax.servlet.jsp:jsp-api:jar:2.1:compile
        [INFO] | +- org.apache.hadoop:hadoop-yarn-server-tests:test-jar:tests:2.1.0-beta:compile
        [INFO] | | - org.apache.hadoop:hadoop-yarn-server-resourcemanager:jar:2.1.0-beta:compile
        [INFO] | - org.apache.hadoop:hadoop-mapreduce-client-hs:jar:2.1.0-beta:compile
        [INFO] +- org.apache.hbase:hbase-hadoop2-compat:test-jar:tests:0.97.0-SNAPSHOT:test

        We can at least remove the dependency to hdfs-test with this modification in the pom.xml
        <dependency>
        <groupId>org.apache.hadoop</groupId>
        <artifactId>hadoop-minicluster</artifactId>
        <version>$

        {hadoop-two.version}

        </version>
        <exclusions>
        <exclusion>
        <!-- We use a newer version of netty -->
        <groupId>org.jboss.netty</groupId>
        <artifactId>netty</artifactId>
        </exclusion>
        <exclusion>
        <groupId>org.apache.hadoop</groupId>
        <artifactId>hadoop-hdfs</artifactId> <========================= new
        </exclusion>
        </exclusions>
        </dependency>


          People

          • Assignee:
            Nicolas Liochon
            Reporter:
            Nicolas Liochon
          • Votes:
            0 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development