HBase
  1. HBase
  2. HBASE-9519

fix NPE in EncodedScannerV2.getFirstKeyInBlock()

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.98.0, 0.96.1
    • Fix Version/s: 0.98.0
    • Component/s: HFile
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      we observed a reproducable NPE while scanning special table under special condition in our IntegratedTesting scenario, it was fixed by appling the attached patch.

      org.apache.hadoop.hbase.client.ScannerCallable@67ee75a5, java.io.IOException: java.io.IOException: java.lang.NullPointerException
      at org.apache.hadoop.hbase.regionserver.HRegionServer.convertThrowableToIOE(HRegionServer.java:1186)
      at org.apache.hadoop.hbase.regionserver.HRegionServer.convertThrowableToIOE(HRegionServer.java:1175)
      at org.apache.hadoop.hbase.regionserver.HRegionServer.openScanner(HRegionServer.java:2391)
      at sun.reflect.GeneratedMethodAccessor24.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.hadoop.hbase.ipc.SecureRpcEngine$Server.call(SecureRpcEngine.java:456)
      at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1426)
      Caused by: java.lang.NullPointerException
      at org.apache.hadoop.hbase.io.hfile.HFileReaderV2$EncodedScannerV2.getFirstKeyInBlock(HFileReaderV2.java:1071)
      at org.apache.hadoop.hbase.io.hfile.HFileReaderV2$AbstractScannerV2.seekBefore(HFileReaderV2.java:547)
      at org.apache.hadoop.hbase.io.HalfStoreFileReader$1.seekBefore(HalfStoreFileReader.java:159)
      at org.apache.hadoop.hbase.io.HalfStoreFileReader$1.seekBefore(HalfStoreFileReader.java:142)
      at org.apache.hadoop.hbase.io.HalfStoreFileReader.getLastKey(HalfStoreFileReader.java:267)
      at org.apache.hadoop.hbase.regionserver.StoreFile$Reader.passesKeyRangeFilter(StoreFile.java:1543)
      at org.apache.hadoop.hbase.regionserver.StoreFileScanner.shouldUseScanner(StoreFileScanner.java:375)
      at org.apache.hadoop.hbase.regionserver.StoreScanner.selectScannersFrom(StoreScanner.java:298)
      at org.apache.hadoop.hbase.regionserver.StoreScanner.getScannersNoCompaction(StoreScanner.java:262)
      at org.apache.hadoop.hbase.regionserver.StoreScanner.<init>(StoreScanner.java:149)
      at org.apache.hadoop.hbase.regionserver.Store.getScanner(Store.java:2122)
      at org.apache.hadoop.hbase.regionserver.HRegion$RegionScannerImpl.<init>(HRegion.java:3460)
      at org.apache.hadoop.hbase.regionserver.HRegion.instantiateRegionScanner(HRegion.java:1645)
      at org.apache.hadoop.hbase.regionserver.HRegion.getScanner(HRegion.java:1635)
      at org.apache.hadoop.hbase.regionserver.HRegion.getScanner(HRegion.java:1610)
      at org.apache.hadoop.hbase.regionserver.HRegionServer.openScanner(HRegionServer.java:2377)
      ... 5 more

      1. HBASE-9519-v2.txt
        2 kB
        Liang Xie
      2. HBASE-9519.txt
        0.9 kB
        Liang Xie

        Activity

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12602753/HBASE-9519.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7181//console

        This message is automatically generated.

        Ted Yu added a comment -

        There seems to be code duplication with updateCurrentBlock().
        Can you extract the common code ?

        What encoding was used that led to NPE ?

        Thanks

        Liang Xie added a comment -

        v2 addressed Ted's comments

        Liang Xie added a comment -

        What encoding was used that led to NPE ?

        Sorry, i don't have the original accident log right now, it was fixed in Aug. IMO, it didn't relate with the exactly detailed encoding algo, it's just an EncodedScannerV2 issue.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12602951/HBASE-9519-v2.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.coprocessor.TestMasterObserver
        org.apache.hadoop.hbase.coprocessor.TestAggregateProtocol
        org.apache.hadoop.hbase.mapred.TestTableInputFormat
        org.apache.hadoop.hbase.mapreduce.TestTimeRangeMapRed
        org.apache.hadoop.hbase.mapreduce.TestRowCounter
        org.apache.hadoop.hbase.io.encoding.TestChangingEncoding
        org.apache.hadoop.hbase.client.TestHTableUtil
        org.apache.hadoop.hbase.mapreduce.TestImportTsv
        org.apache.hadoop.hbase.coprocessor.TestOpenTableInCoprocessor
        org.apache.hadoop.hbase.coprocessor.TestClassLoading
        org.apache.hadoop.hbase.thrift.TestThriftServer
        org.apache.hadoop.hbase.master.cleaner.TestSnapshotFromMaster
        org.apache.hadoop.hbase.trace.TestHTraceHooks
        org.apache.hadoop.hbase.mapreduce.TestCopyTable
        org.apache.hadoop.hbase.mapreduce.TestImportExport
        org.apache.hadoop.hbase.client.TestHTablePool$TestHTableThreadLocalPool
        org.apache.hadoop.hbase.util.TestMergeTool
        org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFiles
        org.apache.hadoop.hbase.security.access.TestTablePermissions
        org.apache.hadoop.hbase.snapshot.TestExportSnapshot
        org.apache.hadoop.hbase.TestZooKeeper
        org.apache.hadoop.hbase.coprocessor.TestRegionServerCoprocessorExceptionWithRemove
        org.apache.hadoop.hbase.client.TestCloneSnapshotFromClient
        org.apache.hadoop.hbase.security.access.TestZKPermissionsWatcher
        org.apache.hadoop.hbase.client.TestClientTimeouts
        org.apache.hadoop.hbase.client.TestSnapshotCloneIndependence
        org.apache.hadoop.hbase.master.TestMasterFailoverBalancerPersistence
        org.apache.hadoop.hbase.mapreduce.TestTableInputFormatScan2
        org.apache.hadoop.hbase.client.TestFromClientSideNoCodec
        org.apache.hadoop.hbase.util.hbck.TestOfflineMetaRebuildOverlap
        org.apache.hadoop.hbase.client.TestMultiParallel
        org.apache.hadoop.hbase.mapred.TestTableMapReduce
        org.apache.hadoop.hbase.util.hbck.TestOfflineMetaRebuildBase
        org.apache.hadoop.hbase.security.access.TestAccessControlFilter
        org.apache.hadoop.hbase.coprocessor.TestRegionServerCoprocessorExceptionWithAbort
        org.apache.hadoop.hbase.thrift.TestThriftServerCmdLine
        org.apache.hadoop.hbase.regionserver.TestHRegion
        org.apache.hadoop.hbase.client.TestTimestampsFilter
        org.apache.hadoop.hbase.util.TestRegionSplitter
        org.apache.hadoop.hbase.catalog.TestMetaMigrationConvertingToPB
        org.apache.hadoop.hbase.client.TestMetaScanner
        org.apache.hadoop.hbase.master.snapshot.TestSnapshotFileCache
        org.apache.hadoop.hbase.coprocessor.TestRegionObserverBypass
        org.apache.hadoop.hbase.client.TestAdmin
        org.apache.hadoop.hbase.client.TestMultipleTimestamps
        org.apache.hadoop.hbase.master.TestAssignmentManagerOnCluster
        org.apache.hadoop.hbase.master.handler.TestCreateTableHandler
        org.apache.hadoop.hbase.master.TestMasterMetricsWrapper
        org.apache.hadoop.hbase.master.TestMasterRestartAfterDisablingTable
        org.apache.hadoop.hbase.TestAcidGuarantees
        org.apache.hadoop.hbase.master.TestRollingRestart
        org.apache.hadoop.hbase.regionserver.TestHRegionOnCluster
        org.apache.hadoop.hbase.TestFullLogReconstruction
        org.apache.hadoop.hbase.coprocessor.TestRegionObserverScannerOpenHook
        org.apache.hadoop.hbase.client.TestRestoreSnapshotFromClient
        org.apache.hadoop.hbase.coprocessor.TestBigDecimalColumnInterpreter
        org.apache.hadoop.hbase.mapreduce.TestTableMapReduce
        org.apache.hadoop.hbase.mapreduce.TestWALPlayer
        org.apache.hadoop.hbase.client.TestScannersFromClientSide
        org.apache.hadoop.hbase.coprocessor.TestMasterCoprocessorExceptionWithRemove
        org.apache.hadoop.hbase.mapreduce.TestCellCounter
        org.apache.hadoop.hbase.TestIOFencing
        org.apache.hadoop.hbase.regionserver.TestCompaction
        org.apache.hadoop.hbase.mapreduce.TestHLogRecordReader
        org.apache.hadoop.hbase.master.TestMasterTransitions
        org.apache.hadoop.hbase.client.TestScannerTimeout
        org.apache.hadoop.hbase.client.TestClientScannerRPCTimeout
        org.apache.hadoop.hbase.util.TestMergeTable
        org.apache.hadoop.hbase.regionserver.TestServerCustomProtocol
        org.apache.hadoop.hbase.client.TestShell
        org.apache.hadoop.hbase.master.TestRestartCluster
        org.apache.hadoop.hbase.mapreduce.TestMultithreadedTableMapper
        org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFilesSplitRecovery
        org.apache.hadoop.hbase.coprocessor.TestMasterCoprocessorExceptionWithAbort
        org.apache.hadoop.hbase.util.TestMiniClusterLoadParallel
        org.apache.hadoop.hbase.client.TestHTablePool$TestHTableReusablePool
        org.apache.hadoop.hbase.TestDrainingServer
        org.apache.hadoop.hbase.util.TestMiniClusterLoadSequential
        org.apache.hadoop.hbase.master.TestMasterFileSystem
        org.apache.hadoop.hbase.master.TestZKBasedOpenCloseRegion
        org.apache.hadoop.hbase.zookeeper.TestZooKeeperACL
        org.apache.hadoop.hbase.util.TestCoprocessorScanPolicy
        org.apache.hadoop.hbase.master.TestOpenedRegionHandler
        org.apache.hadoop.hbase.io.TestFileLink
        org.apache.hadoop.hbase.master.TestMasterMetrics
        org.apache.hadoop.hbase.client.TestHTableMultiplexer
        org.apache.hadoop.hbase.mapreduce.TestLoadIncrementalHFiles
        org.apache.hadoop.hbase.master.TestMasterFailover
        org.apache.hadoop.hbase.mapreduce.TestLoadIncrementalHFilesSplitRecovery
        org.apache.hadoop.hbase.backup.TestHFileArchiving
        org.apache.hadoop.hbase.master.TestTableLockManager
        org.apache.hadoop.hbase.master.handler.TestTableDescriptorModification
        org.apache.hadoop.hbase.coprocessor.TestRowProcessorEndpoint
        org.apache.hadoop.hbase.mapreduce.TestHRegionPartitioner
        org.apache.hadoop.hbase.client.TestHCM
        org.apache.hadoop.hbase.master.TestMasterShutdown
        org.apache.hadoop.hbase.client.TestSnapshotFromClient
        org.apache.hadoop.hbase.coprocessor.TestWALObserver
        org.apache.hadoop.hbase.snapshot.TestFlushSnapshotFromClient
        org.apache.hadoop.hbase.client.TestFromClientSide
        org.apache.hadoop.hbase.util.TestMiniClusterLoadEncoded
        org.apache.hadoop.hbase.master.TestRegionPlacement
        org.apache.hadoop.hbase.client.TestFromClientSide3
        org.apache.hadoop.hbase.client.TestFromClientSideWithCoprocessor
        org.apache.hadoop.hbase.mapreduce.TestTableInputFormatScan1
        org.apache.hadoop.hbase.security.access.TestAccessController
        org.apache.hadoop.hbase.TestLocalHBaseCluster
        org.apache.hadoop.hbase.catalog.TestMetaReaderEditor
        org.apache.hadoop.hbase.snapshot.TestRestoreFlushSnapshotFromClient
        org.apache.hadoop.hbase.coprocessor.TestCoprocessorEndpoint
        org.apache.hadoop.hbase.master.TestDistributedLogSplitting
        org.apache.hadoop.hbase.util.TestFSUtils
        org.apache.hadoop.hbase.util.hbck.TestOfflineMetaRebuildHole
        org.apache.hadoop.hbase.mapreduce.TestHFileOutputFormat
        org.apache.hadoop.hbase.coprocessor.TestRegionObserverInterface
        org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster
        org.apache.hadoop.hbase.master.cleaner.TestHFileCleaner
        org.apache.hadoop.hbase.master.TestMaster
        org.apache.hadoop.hbase.io.encoding.TestLoadAndSwitchEncodeOnDisk
        org.apache.hadoop.hbase.regionserver.wal.TestLogRolling
        org.apache.hadoop.hbase.util.TestHBaseFsck
        org.apache.hadoop.hbase.regionserver.TestClusterId

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7206//console

        This message is automatically generated.

        Ted Yu added a comment -

        i don't have the original accident log right now

        Keeping log would be nice.

        Looks like there is some issue with build environment. Can you run test suite and post the result here ?

        Thanks

        stack added a comment -

        Keeping log would be nice.

        Ted Yu What kind of an 'old lady' statement is that to make ('nice')? Who are you to tell folks how they should do log retention? Statements like the above only pisses folks off (me for example, and likely the person this statement was directed at).

        Liang Xie added a comment -

        take it easy, nobody is pissed off

        could we kick off another QA run manually on build server?

        stack added a comment -

        Liang Xie I started it here https://builds.apache.org/view/H-L/view/HBase/job/PreCommit-HBASE-Build/7227/ but hadoopqa is having some issues; one of its disks is full.... maybe this build will work.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12602951/HBASE-9519-v2.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7227//console

        This message is automatically generated.

        stack added a comment -

        Javadoc warning is from elsewhere. I don't know this code very well. Patch lgtm w/ this caveat.

        Liang Xie added a comment -

        any more comments? thanks

        stack added a comment -

        Anyone else want to check this? Otherwise will commit tomorrow to trunk.

        Liang Xie added a comment -

        any more comments? or could it go ahead to trunk?

        Ted Yu added a comment -

        Integrated to trunk.

        Hudson added a comment -

        FAILURE: Integrated in HBase-TRUNK #4554 (See https://builds.apache.org/job/HBase-TRUNK/4554/)
        HBASE-9519 fix NPE in EncodedScannerV2.getFirstKeyInBlock() (tedyu: rev 1525953)

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #759 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/759/)
        HBASE-9519 fix NPE in EncodedScannerV2.getFirstKeyInBlock() (tedyu: rev 1525953)

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java

          People

          • Assignee:
            Liang Xie
            Reporter:
            Liang Xie
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development