HBase
  1. HBase
  2. HBASE-9009

Disable TestMultiTableInputFormat

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.95.2
    • Component/s: None
    • Labels:
      None
    • Release Note:
      Removed this set of tests.

      Description

      I am going to try removing this test. There is something odd about it. When I compare the list of tests that succeed in a green test run, this one is often 'missing'. For example, see:

      http://54.241.6.143/job/HBase-0.95/661/org.apache.hbase$hbase-server/consoleText

      All tests 'passed'. Says

      Tests run: 1587, Failures: 0, Errors: 0, Skipped: 17

      Test run 659 just before it, http://54.241.6.143/job/HBase-0.95/659/, says:

      Tests run: 1592, Failures: 0, Errors: 0, Skipped: 17

      TestMultiTableInputFormat runs five tests so this could be the difference in test run numbers above.

      I am going to remove this set of tests for now.

      I am a little stuck when I have test runs where all tests 'complete' but yet the build fails. My zombie tracker doesn't trigger anymore so this is a new form of fail.

        Issue Links

          Activity

          stack added a comment -

          Disabled by removing the test completely

          stack added a comment -

          Committed to trunk.

          stack added a comment -

          This test should be disabled because it runs for too long nevermind it has this mystery aspect:

          Running org.apache.hadoop.hbase.mapreduce.TestMultiTableInputFormat
          Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 896.918 sec
          
          Liu Shaohui added a comment -

          stack
          In HBASE-10692, i will try to restore the test: TestMultiTableInputFormat, and then add a test: TestSecureMultiTableInputFormat.

          I rerun the test for several times and it passed.

          Running org.apache.hadoop.hbase.mapreduce.TestMultiTableInputFormat
          Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 314.163 sec
          

          How to reproduce the odd problem you mentioned above? Any suggestion? THX


            People

            • Assignee:
              Unassigned
              Reporter:
              stack
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development