HBase
  1. HBase
  2. HBASE-8532

[Webui] Bootstrap based webui compatibility for IE and also fix some page format issues.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.98.0, 0.95.0, 0.95.2
    • Fix Version/s: 0.98.0, 0.95.2
    • Component/s: UI
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      HBASE-7425 brings bootstrap based webui to hbase. While trying on trunk version, Firefox works well, but IE 8/9 layout and style look strange due to compatibility issue. Add "<!DOCTYPE html ...>" at the beginning of all jamon html/jsp templates to fix it.

      Seems HBase-2110 had a work to comment out the DOCTYPE for all .jsp to make the browser run the pages in Quirks mode (http://en.wikipedia.org/wiki/Quirks_mode) due to jetty issue at that time?

      To support the compatibility of webui across browsers (IE/Firefox/Chrome, etc.), there are some guidelines for choosing rendering the page under standard mode or quirk mode:
      http://en.wikipedia.org/wiki/Quirks_mode
      http://hsivonen.iki.fi/doctype/

      According to document, "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">" has the most extensive compatibility even for HTML 5. According to my test, add this could make webui works in IE (standard mode), while Firefox could not work well with styles. Looks like if in Firefox, we still need the quirk mode (no DOCTYPE declaration).

      So just adding conditional DOCTYPE declaration for IE,
      <!--[if IE]>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
      <![endif]-->
      this could make webui works for both IE and Firefox, also for Chrome and other browsers.

      1. 8532-trunk-0.95-v1.patch
        7 kB
        Julian Zhou
      2. hbase-8532_v0.patch
        6 kB
        Julian Zhou
      3. webui-IE-error.png
        43 kB
        Julian Zhou
      4. webui-IE-error-&apos;.png
        41 kB
        Julian Zhou

        Issue Links

          Activity

          Julian Zhou added a comment -

          This is a master status page sample that has layout/style issue in IE 8/9.

          Jean-Marc Spaggiari added a comment -

          Hi Julian Zhou, have you tried with the other browsers and IE versions to make sure it's still working for them? I guess there is no impact for non-IE browsers, but what's about IE 7 and before? Still working fine?

          Julian Zhou added a comment -

          Hi Jean-Marc,
          Yes, the issue is for IE, so added conditional DOCTYPE for IE. I only got IE 8/9, could not find IE version older than 7 (including 7) . Maybe that's the case for most of PC users. Other browser works fine including Firefox 20.0.1, Chrome 26.0.1410.64 (other browsers with Webkit engine should be ok as well), Opera 12.15, Safari 5.1.9.

          Jean-Marc Spaggiari added a comment -

          I have access to a IE7 if we want. But the real question should be do we want to support IE7? I mean, it's a pretty old version of IE, should we have an official list of supporter browsers for the WEBUIs?

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12582835/hbase-8532_v0.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.security.access.TestAccessController
          org.apache.hadoop.hbase.client.TestHCM

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5646//console

          This message is automatically generated.

          Julian Zhou added a comment -

          Hi, Jean-Marc Spaggiari, thanks if having a try on the patch on the trunk for IE 7. Feel that documenting the browsers supported should make sense for release.

          Julian Zhou added a comment -

          IETester(http://www.my-debugbar.com/wiki/IETester/HomePage) is a tool for testing page in different IE versions.
          Seems there still got css rendering issue in IE 9 in standard mode.

          There is another issue for IE 8 and older versions. IE 8 and older versions could not recognize "'" as "'". So we should use entity code "'" instead for "'". This issue is introduced by "escapeXML()" function added in .jsp pages. excapeXML will convert the "'" to "'". But in some way, may need to convert to "'" for the case of IE 8 (IE 9 looks like already support to recognize "'").

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12582941/webui-IE-error-%26apos%3B.png
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5653//console

          This message is automatically generated.

          Jean-Marc Spaggiari added a comment -

          Seems that IE7 support is not required. So if you tried with 8 and 9, then you are all good.

          Elliott Clark added a comment -

          I'll try this tonight or tomorrow on a cluster.

          Julian Zhou added a comment -

          Hi, Elliott Clark, could you help review the patch? This one also includes some refinement and format correction on the pages. Webkit based and IE 8 browsers have been tested in production environment. The patch is for trunk and 0.95 both. Thanks~

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12584891/8532-trunk-0.95-v1.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 lineLengths. The patch introduces lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5836//console

          This message is automatically generated.

          stack added a comment -

          Elliott Clark Review? Thanks boss.

          Elliott Clark added a comment -

          +1 sorry it took so long. I had a harder time getting an old ie than I thought I would. Looks good. THanks Julian

          stack added a comment -

          Committed trunk and 0.95. Thanks Julian (and E for review).

          Hudson added a comment -

          Integrated in hbase-0.95 #265 (See https://builds.apache.org/job/hbase-0.95/265/)
          HBASE-8532 [Webui] Bootstrap based webui compatibility for IE and also fix some page format issues (Revision 1496162)

          Result = SUCCESS
          stack :
          Files :

          • /hbase/branches/0.95/hbase-server/src/main/jamon/org/apache/hadoop/hbase/tmpl/master/MasterStatusTmpl.jamon
          • /hbase/branches/0.95/hbase-server/src/main/jamon/org/apache/hadoop/hbase/tmpl/regionserver/RSStatusTmpl.jamon
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/snapshot.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/table.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/tablesDetailed.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/zk.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/rest/rest.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/thrift/thrift.jsp
          Hudson added a comment -

          Integrated in hbase-0.95-on-hadoop2 #147 (See https://builds.apache.org/job/hbase-0.95-on-hadoop2/147/)
          HBASE-8532 [Webui] Bootstrap based webui compatibility for IE and also fix some page format issues (Revision 1496162)

          Result = FAILURE
          stack :
          Files :

          • /hbase/branches/0.95/hbase-server/src/main/jamon/org/apache/hadoop/hbase/tmpl/master/MasterStatusTmpl.jamon
          • /hbase/branches/0.95/hbase-server/src/main/jamon/org/apache/hadoop/hbase/tmpl/regionserver/RSStatusTmpl.jamon
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/snapshot.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/table.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/tablesDetailed.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/master/zk.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/rest/rest.jsp
          • /hbase/branches/0.95/hbase-server/src/main/resources/hbase-webapps/thrift/thrift.jsp
          Hudson added a comment -

          Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #582 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/582/)
          HBASE-8532 [Webui] Bootstrap based webui compatibility for IE and also fix some page format issues (Revision 1496164)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/jamon/org/apache/hadoop/hbase/tmpl/master/MasterStatusTmpl.jamon
          • /hbase/trunk/hbase-server/src/main/jamon/org/apache/hadoop/hbase/tmpl/regionserver/RSStatusTmpl.jamon
          • /hbase/trunk/hbase-server/src/main/resources/hbase-webapps/master/snapshot.jsp
          • /hbase/trunk/hbase-server/src/main/resources/hbase-webapps/master/table.jsp
          • /hbase/trunk/hbase-server/src/main/resources/hbase-webapps/master/tablesDetailed.jsp
          • /hbase/trunk/hbase-server/src/main/resources/hbase-webapps/master/zk.jsp
          • /hbase/trunk/hbase-server/src/main/resources/hbase-webapps/rest/rest.jsp
          • /hbase/trunk/hbase-server/src/main/resources/hbase-webapps/thrift/thrift.jsp

            People

            • Assignee:
              Julian Zhou
              Reporter:
              Julian Zhou
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development