HBase
  1. HBase
  2. HBASE-8374

NullPointerException when launching the balancer due to unknown region location

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.95.0
    • Fix Version/s: 0.98.0, 0.95.1
    • Component/s: Balancer
    • Labels:
      None
    • Environment:

      AWS / real cluster with 3 nodes + master

    • Hadoop Flags:
      Reviewed

      Description

      I don't reproduce this all the time, but I had it on a fairly clean env.
      It occurs every 5 minutes (i.e. the balancer period). Impact is severe: the balancer does not run. When it starts to occurs, it occurs all the time. I haven't tried to restart the master, but I think it should be enough.
      Now, looking at the code, the NPE is strange.

      2013-04-18 08:09:52,079 ERROR [box,60000,1366281581983-BalancerChore] org.apache.hadoop.hbase.master.balancer.BalancerChore: Caught exception
      java.lang.NullPointerException
      	at org.apache.hadoop.hbase.master.balancer.BaseLoadBalancer$Cluster.<init>(BaseLoadBalancer.java:145)
      	at org.apache.hadoop.hbase.master.balancer.StochasticLoadBalancer.balanceCluster(StochasticLoadBalancer.java:194)
      	at org.apache.hadoop.hbase.master.HMaster.balance(HMaster.java:1295)
      	at org.apache.hadoop.hbase.master.balancer.BalancerChore.chore(BalancerChore.java:48)
      	at org.apache.hadoop.hbase.Chore.run(Chore.java:81)
      	at java.lang.Thread.run(Thread.java:662)
      2013-04-18 08:09:52,103 DEBUG [box,60000,1366281581983-CatalogJanitor] org.apache.hadoop.hbase.client.ClientScanner: Creating scanner over .META. starting at key ''
      
                if (regionFinder != null) {
                  //region location
                  List<ServerName> loc = regionFinder.getTopBlockLocations(region);
                  regionLocations[regionIndex] = new int[loc.size()];
                  for (int i=0; i < loc.size(); i++) {
                    regionLocations[regionIndex][i] = serversToIndex.get(loc.get(i));  // <========= NPE here
                  }
                }
      

      pinging Enis Soztutar, just in case.

      1. 8374-trunk.txt
        1 kB
        Ted Yu
      2. 8374-trunk-v2.txt
        0.8 kB
        Ted Yu
      3. 8374-trunk-v3.txt
        0.9 kB
        Ted Yu
      4. 8374-trunk-v4.txt
        3 kB
        Ted Yu
      5. 8374-trunk-v5.txt
        2 kB
        Ted Yu

        Activity

        Ted Yu added a comment -

        I think loc was empty, leading to NPE.

        Here is a patch.

        Jean-Marc Spaggiari added a comment -

        Hi Ted,

        I'm not sure about your patch.

        +            if (loc.size() > 0) {
        +              regionLocations[regionIndex] = new int[loc.size()];
        +              for (int i=0; i < loc.size(); i++) {
        +                regionLocations[regionIndex][i] = serversToIndex.get(loc.get(i));
        +              }
                     }
        

        If loc.size() == 0, then the for loop will never run and the loc.get will never be called. No? And we know that loc can't be null else the NPE will have been on loc.size(). So 2 options.
        1) log.get returns null and serversToIndex.get(null) give the NPE
        2) serversToIndex is null.

        I think we are facing #1 here.

        Ted Yu added a comment -

        If loc.size() == 0, there is no information to fill in regionLocations.
        serversToIndex.get() call would be skipped, avoiding NPE.

        Jean-Marc Spaggiari added a comment -

        My point is that serversToIndex.get() was already skipped with loc.size() == 0 because of the for. So I agree that adding the test will avoid the creation of the regionLocations array, but it will not fix the NPE error since it occured when loc.size() was > 0.

        Ted Yu added a comment -

        Patch v2 addresses the case where (some) ServerName couldn't be determined by regionFinder.getTopBlockLocations()

        Nicolas Liochon added a comment -

        I think it's serversToIndex.get(loc.get); that returns null. As it's an Integer it's then casted to int, hence the NPE. So v2 does not remove the NPE imho.
        I added some tests locally, but I've not yet reproduced it, so I can't say for sure. If so, the question would be: why does it happen?

        Ted Yu added a comment -

        See if patch v3 is better.

        Jean-Marc Spaggiari added a comment -

        Hum, not sure. regionLocations[regionIndex][i] is int. If yo uassign null to it you will still get the NPE.

        Also, as Nicolas is saying, "the question would be: why does it happen? "

        Ted Yu added a comment -

        w.r.t. Nicolas' question, I think what happened was that serversToIndex map wasn't fully populated because one loop was used to iterate through clusterState.entrySet().

        In patch v4, I introduced another loop to populate serversToIndex map.

        I kept the checking from patch v3 in case regionFinder.getTopBlockLocations() returns some ServerName which is not in serversToIndex map.

        Jean-Marc Spaggiari added a comment -

        Make sense!

        I'm +4 with patch v4.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12579361/8374-trunk-v3.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5346//console

        This message is automatically generated.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12579365/8374-trunk-v4.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5348//console

        This message is automatically generated.

        Enis Soztutar added a comment -

        Nice bug. Agree that serversToIndex is not populated first. Also it might happen that RegionLocationFinder might return region locations that we do not know about (the RS might have died, and we could be caching the data, etc). We should still guard against serversToIndex.get(loc.get) returning null.
        For the patch, we should not use boxed primitives (for regionLocations = new int[numRegions][]. We can use -1, to indicate a null value.

        Ted Yu added a comment -

        Patch v5 changes regionLocations back to int array.

        Enis Soztutar added a comment -

        lgtm. Thanks Ted for taking this on. Nicolas, any chance you can try this with the cluster?

        Nicolas Liochon added a comment -

        I will do that tomorrow, thanks for the patch and the reviews!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12579422/8374-trunk-v5.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.security.access.TestAccessController

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5350//console

        This message is automatically generated.

        Nicolas Liochon added a comment -

        No occurrence since I install the patch. +1 from me.

        Ted Yu added a comment -

        Integrated to 0.95 and trunk.

        Thanks for the reviews, Nicolas, Jean-Marc and Enis.

        Hudson added a comment -

        Integrated in HBase-TRUNK #4071 (See https://builds.apache.org/job/HBase-TRUNK/4071/)
        HBASE-8374 NullPointerException when launching the balancer due to unknown region location (Ted Yu) (Revision 1469954)

        Result = FAILURE
        tedyu :
        Files :

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/BaseLoadBalancer.java
        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/StochasticLoadBalancer.java
        Hudson added a comment -

        Integrated in hbase-0.95 #154 (See https://builds.apache.org/job/hbase-0.95/154/)
        HBASE-8374 NullPointerException when launching the balancer due to unknown region location (Ted Yu) (Revision 1469955)

        Result = FAILURE
        tedyu :
        Files :

        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/BaseLoadBalancer.java
        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/StochasticLoadBalancer.java
        Hudson added a comment -

        Integrated in hbase-0.95-on-hadoop2 #75 (See https://builds.apache.org/job/hbase-0.95-on-hadoop2/75/)
        HBASE-8374 NullPointerException when launching the balancer due to unknown region location (Ted Yu) (Revision 1469955)

        Result = FAILURE
        tedyu :
        Files :

        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/BaseLoadBalancer.java
        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/StochasticLoadBalancer.java
        Hudson added a comment -

        Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #505 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/505/)
        HBASE-8374 NullPointerException when launching the balancer due to unknown region location (Ted Yu) (Revision 1469954)

        Result = FAILURE
        tedyu :
        Files :

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/BaseLoadBalancer.java
        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/balancer/StochasticLoadBalancer.java

          People

          • Assignee:
            Ted Yu
            Reporter:
            Nicolas Liochon
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development