HBase
  1. HBase
  2. HBASE-814

JSON Rest Regular (No Transaction)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.20.0
    • Component/s: REST
    • Labels:
      None

      Description

      This is the first patch for JSONRest. It contains the non-transactional part of JSONRest without the unit tests. Since JSONRest is very modular, the transaction part of it is just an extension of normal JSONRest and is not needed to use normal JSONRest

      The unit tests are still being built and are not ready yet and so will be submitted later (they work, the main issue is that I have been using faked data with the perl faker module. I need to just generate a dataset and use it. Sometimes gimicky cool things like generating random data for my tests grab me... for better or worse).

      To emphasize this I have decided to submit 2 patches, JSONRest and transactional JSONRest.

      I will attach the unit tests in a few days once they have been completed and are in a form that Hudson can use them.

      1. patch.diff
        100 kB
        Michael Gottesman

        Activity

        stack added a comment -

        This JSON stuff and Michaels' JSON jar are the underpinnings of the current hbase REST implementation as done by Brian Beggs under aegis of hbase-1064. Resolving as duplicate of that issue.

        stack added a comment -

        Michael:

        Whats the license on the json jar and where's the source?

        Add an apache license to all of your new class files.

        Would also suggest you add package-level documentation like the thrift packages. Would help people get off the ground (Copy the wiki page down here?).

        Otherwise patch looks excellent.

        Michael Gottesman added a comment -

        You need my json2 library to use it. You can get it here: http://people.reed.edu/~gottesmm/json2.jar.

        Michael Gottesman added a comment -

        Version 1


          People

          • Assignee:
            Unassigned
            Reporter:
            Michael Gottesman
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development