Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.94.0
    • Fix Version/s: None
    • Component/s: Client
    • Labels:
    • Environment:

      hadoop-1.0.2 hbase-0.94.0

      Description

      when hconnection is used by one matchine,the connection return to the pool. if anather matchine reget the connection,it can be resued.
      but in the code the caching map don't be managered correctly

        Activity

        Anoop Sam John added a comment -

        Have you attached any patch? I can not see any but you made status as Patch Available

        Anoop Sam John added a comment -

        Ya it is there now

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12573031/HConnectionManager-connection-could-not-reuse.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/4752//console

        This message is automatically generated.

        ramkrishna.s.vasudevan added a comment -

        Am not sure if this is a bug.
        The rsname and the

        Addressing.createHostAndPortStr(
                          address.getHostName(), address.getPort()
        

        resolve to the same String right? So the lookup from map should be ok?

        Anoop Sam John added a comment -

        Ram
        I was also wondering and was looking more into Trunk code also.
        @Yuan can you pls explain

        Anoop Sam John added a comment -

        And also see

        InetSocketAddress address = isa != null? isa:
                        new InetSocketAddress(hostname, port);
        

        address creation is also in the same way as rsname

        Anoop Sam John added a comment -

        Will test with some test cases.

        Yuan Kang added a comment -

        In my app,I find this two String sometimes isn't the same,sometimes it's ip,another time it's hostname because the parameter hostname and InetSocketAddress is conflict. using the same parmeter is prefer to geting another.

        Yuan Kang added a comment -

        I found in hbase trunk there is no getHRegionConnection() method yet,it have been replaced by getProtocol().this bug may be fixed by someone else. in the trunk code(At revision 1461481) line 1512 "protocols.put(protocol, server);" the map key is replaced by protocol.

        Anoop Sam John added a comment -

        I just tested this in my local env and am not able to see the mentioned issue.

        >In my app,I find this two String sometimes isn't the same,sometimes it's ip,another time it's hostname
        You mean the param,hostname coming into method getHRegionConnection(final String hostname, final int port,final InetSocketAddress isa, final boolean master)?


          People

          • Assignee:
            Unassigned
            Reporter:
            Yuan Kang
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development