HBase
  1. HBase
  2. HBASE-7640

FSUtils#getTableStoreFilePathMap should ignore non-hfiles.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      ERROR: Found lingering reference file
      hdfs://node3:9000/hbase/entry_proposed/fbd1735591467005e53f48645278b006/recovered.edits/0000000000091843039.temp

      recovered.edits is not a column family.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          502d 22h 52m 1 Andrew Purtell 08/Jun/14 22:36
          Andrew Purtell made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]
          Andrew Purtell added a comment -

          Stale issue. Reopen if still relevant.

          Matteo Bertozzi added a comment -

          At the moment we have under the region folder

          • HRegion.MERGEDIR = ".merges"
          • HRegion.REGION_TEMP_SUBDIR = ".tmp"
          • SplitTransaction.SPLITDIR = ".splits"
          • HLog.RECOVERED_EDITS_DIR = "recovered.edits"; (Valid CF since doesn't start with .)
          • HLogSplitter.RECOVERED_EDITS_DIR = "recovered.edits"; (Duplicate of above)

          Times ago I've started moving out filesystem code from the region... but we have lots of stuff that hardcode names and paths.
          https://github.com/matteobertozzi/hbase/commit/ffe638d06b479c3e7d84898c79cb90205fb17956#L2R191

          I'm +1 to move all the related constants to one place

          Jimmy Xiang made changes -
          Field Original Value New Value
          Link This issue relates to HBASE-7108 [ HBASE-7108 ]
          Jimmy Xiang added a comment -

          I see. Do we have a list of special names which can not be column family names?
          We should consolidate those public constants in some central places (for example, HConstants, but doesn't have to be just one class).
          So that we can avoid such confusion. I still see recovered.edits is used a system folder in some test code.

          Matteo Bertozzi added a comment -

          recovered.edits is a valid column family at the moment see HBASE-7108

          Jimmy Xiang created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Jimmy Xiang
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development