HBase
  1. HBase
  2. HBASE-7527

integration tests STILL won't run from tar.gz in trunk

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.95.2
    • Fix Version/s: 0.95.0
    • Component/s: test
    • Labels:
      None

      Description

      The problem is that the class used to find test classes sits in common test jar, which is not included in the package.
      However, if we move the class to the common jar itself, we'll have a JUnit dependency.
      And if we cannot just move it to integration tests, because a test that verifies test categories makes use of it too.
      This is all very sad.
      I will see if there's any way to not have junit dependency (we already seem to deploy junit so it might not be such a big deal).

      1. HBASE-7527-v0.patch
        1 kB
        Sergey Shelukhin
      2. HBASE-7527-v1.patch
        2 kB
        Sergey Shelukhin

        Activity

        stack added a comment -

        Marking closed.

        Hudson added a comment -

        Integrated in HBase-TRUNK #3760 (See https://builds.apache.org/job/HBase-TRUNK/3760/)
        HBASE-7527. Integration tests STILL won't run from tar.gz in trunk (Sergey Shelukhin) (Revision 1434539)

        Result = FAILURE
        enis :
        Files :

        • /hbase/trunk/pom.xml
        • /hbase/trunk/src/assembly/components.xml
        Hudson added a comment -

        Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #351 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/351/)
        HBASE-7527. Integration tests STILL won't run from tar.gz in trunk (Sergey Shelukhin) (Revision 1434539)

        Result = FAILURE
        enis :
        Files :

        • /hbase/trunk/pom.xml
        • /hbase/trunk/src/assembly/components.xml
        Enis Soztutar added a comment -

        Committed this. Thanks Sergey.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12565043/HBASE-7527-v1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 2 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.client.TestFromClientSideWithCoprocessor
        org.apache.hadoop.hbase.TestLocalHBaseCluster

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/4036//console

        This message is automatically generated.

        Enis Soztutar added a comment -

        Cool, I'll commit the patch shortly.

        Sergey Shelukhin added a comment -

        Runtime works.

        Enis Soztutar added a comment -

        Strange that in 0.94, junit dependency has runtime scope, but in trunk it has test. Can you please test with runtime scope?

        Sergey Shelukhin added a comment -

        Doesn't work. I think scope prevents it from being packaged when main pom is built and main tar.gz is created.

        Enis Soztutar added a comment -

        Why make junit a main dependency instead of test?

        -        <scope>test</scope>
        

        If hbase-it depends on it, can we do add junit in main scope there?

        Sergey Shelukhin added a comment -

        There's no code change, so findbugs warning is probably bogus.
        Enis Soztutar can you please review?

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12564497/HBASE-7527-v0.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/3983//console

        This message is automatically generated.

        Sergey Shelukhin added a comment -

        Integration tests rely on lots of code from common test so it looks like deploying common test jar is the only viable solution unless another project is created.


          People

          • Assignee:
            Sergey Shelukhin
            Reporter:
            Sergey Shelukhin
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development