HBase
  1. HBase
  2. HBASE-7447

Occasional failures of TestSplitLogWorker#testAcquireTaskAtStartup

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.94.4
    • Fix Version/s: None
    • Component/s: test
    • Labels:
      None

      Description

      I see occasional failures (1 out of ~20) on branch 0.94 of TestSplitLogWorker#testAcquireTaskAtStartup

      Running org.apache.hadoop.hbase.regionserver.TestSplitLogWorker
      Tests run: 5, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 4.737 sec <<< FAILURE!
      Failed tests:
          testAcquireTaskAtStartup(org.apache.hadoop.hbase.regionserver.TestSplitLogWorker): ctr=0, oldval=0, newval=1
      

      Bisecting commits on 0.94 branch, using (up to) 50 repetitions to include or exclude, I get:

      8cc5a5f481aeaf6debfa95110c4392d9c3ea20ca is the first bad commit
      commit 8cc5a5f481aeaf6debfa95110c4392d9c3ea20ca
          HBASE-7172 TestSplitLogManager.testVanishingTaskZNode() fails when run individually and is flaky
          git-svn-id: https://svn.apache.org/repos/asf/hbase/branches/0.94@1414975 13f79535-47bb-0310-9956-ffa450edef68
      

      Will try again to see if the search ends in the same place.

        Activity

        Andrew Purtell created issue -
        Himanshu Vashishtha added a comment -

        What's the stack trace? HBASE-6528 might be related.

        Lars Hofhansl added a comment -

        Thanks Andy!

        Andrew Purtell added a comment -

        Not sure that's a good bisection. Trying again with 100 reps.

        Andrew Purtell added a comment -

        I don't get a good read with bisection, it may just be flaky. Attached is test output as requested.

        Andrew Purtell made changes -
        Andrew Purtell added a comment -

        Resolving as duplicate of HBASE-6528.

        Andrew Purtell made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 18h 13m 1 Andrew Purtell 30/Dec/12 23:15

          People

          • Assignee:
            Unassigned
            Reporter:
            Andrew Purtell
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development