Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-7088

Duplicate code in RowCounter

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 0.96.1, 0.94.14, 0.98.1, 0.99.0
    • 0.99.0
    • mapreduce
    • Reviewed

    Description

      On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:

          if (qualifiers.size() == 0) {
            scan.setFilter(new FirstKeyOnlyFilter());
          } else {
            scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
          }
      

      Should the line 125 simply be removed?

      Attachments

        1. HBASE-7088-v2-trunk.patch
          0.6 kB
          Jean-Marc Spaggiari
        2. HBASE-7088-v1-trunk.patch
          0.6 kB
          Jean-Marc Spaggiari
        3. HBASE-7088.patch
          0.7 kB
          Jean-Marc Spaggiari

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            jmspaggi Jean-Marc Spaggiari
            jmspaggi Jean-Marc Spaggiari
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified

                Slack

                  Issue deployment