HBase
  1. HBase
  2. HBASE-6920

On timeout connecting to master, client can get stuck and never make progress

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.94.2
    • Fix Version/s: 0.94.2
    • Component/s: None
    • Labels:
      None

      Description

      HBASE-5058 appears to have introduced an issue where a timeout in HConnection.getMaster() can cause the client to never be able to connect to the master. So, for example, an HBaseAdmin object can never successfully be initialized.

      The issue is here:

      if (tryMaster.isMasterRunning()) {
        this.master = tryMaster;
        this.masterLock.notifyAll();
        break;
      }
      

      If isMasterRunning times out, it throws an UndeclaredThrowableException, which is already not ideal, because it can be returned to the application.

      But if the first call to getMaster succeeds, it will set masterChecked = true, which makes us never try to reconnect; that is, we will set this.master = null and just throw MasterNotRunningExceptions, without even trying to connect.

      I tried out a 94 client (actually a 92 client with some 94 patches) on a cluster with some network issues, and it would constantly get stuck as described above.

      1. HBASE-6920.patch
        13 kB
        Gregory Chanan
      2. HBASE-6920-v2.patch
        13 kB
        Gregory Chanan
      3. 6920-addendum.txt
        2 kB
        Lars Hofhansl

        Issue Links

          Activity

          Gregory Chanan added a comment -

          Here is a patch for this issue and a test. The test is more complicated than I would like; I needed to introduce some functions / change some access controls to be able to use my own RPC Invoker. Any suggestions would be welcome.

          Gregory Chanan added a comment -

          Some other points:

          • I have not tried the client app that failed in the description with a patched client yet. I will do that soon.
          • This seems like a pretty serious issue (I literally could not get my app to work with a 94 client), though it's not clear how often users will see it, since it only happens on errors. It's also not new with 0.94.2 so I don't know if it needs to sink the RC. Any opinions?
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12547405/HBASE-6920.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 4 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2986//console

          This message is automatically generated.

          Ted Yu added a comment -

          Great finding, Gregory.

          +     * @return true if should retry
          +     */
          +    private boolean logGetMasterAttemptFailure(int tries, Exception e) {
          

          Please rename the method to reflect the fact that it returns whether we should retry.

          +      LOG.info("getMaster attempt " + tries + " of " + numRetries +
          +        " failed; retrying after sleep of " +
          +        ConnectionUtils.getPauseTime(this.pause, tries), e);
          

          Should the above log be at DEBUG level ?
          Comparing your code and the original, it seems that the return value of true actually means that we shouldn't retry.

          Gregory Chanan added a comment -

          I don't have any opinion on the DEBUG level; if you think that's better I'll change it.

          Good catch on the return value, the javadoc is incorrect.

          Ted Yu added a comment -
          +  /** Construct a client-side proxy object, specifying an InvocationHandler for testing purposes */
          +  VersionedProtocol getProxy(Class<? extends VersionedProtocol> protocol,
          

          Name the above method getProxyForTesting ?

          + * RpcEngine that random throws a SocketTimeoutEngine for testing.
          

          'random' -> 'randomly'
          Please correct the spelling for SocketTimeoutEngine

          Lars Hofhansl added a comment -

          Patch looks good.
          I don't quite grok the changes in HBaseRPC, RpcEngine, and WritableRpcEngine. Are those needed for this to work?

          Lars Hofhansl added a comment -

          Also from the explanation I am not quite sure if this a problem in 0.92 as well.

          Gregory Chanan added a comment -

          I think this is 0.94 only – at least HBASE-5058 is only in 0.94.

          Gregory Chanan added a comment -

          The changes in HBaseRPC, RpcEngine, and WritableRpcEngine are just for the test. I wanted to simulate throwing a SocketTimeoutException on a proxy call, but Mockito can't mock a proxy object as far as I can tell.

          So all those changes are just so I can setup my own RPC Invoker to run, which just randomly throws SocketTimeoutExceptions.

          Gregory Chanan added a comment -

          v2, which fixes the javadoc issue (actually changes the return value of the code).

          I left the LOG as INFO, because that's what it was before; let me know if you disagree.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12547415/HBASE-6920-v2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 4 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2987//console

          This message is automatically generated.

          Lars Hofhansl added a comment -

          +1 on patch after addressing Ted's comments ... (although the RPC changes look a bit scary).

          Gregory Chanan added a comment -

          Lars – you have an idea for how to do the test without making RPC changes? I'd prefer that, but couldn't think of a way.

          Lars Hofhansl added a comment -

          Hmm... Not offhand.

          Looking at the patch again... Will this actually fix the problem? The problem is that masterChecked is true when we successfully connected to a master once. If true, we do not try again.
          So we were successful once, we will never enter the retry loop (since masterChecked == true)... Right?

          I wonder whether another approach would be to set masterChecked = false at the same spot where master is set to null, but only do that if master was not-null before.

          Gregory Chanan added a comment -

          Lars, good question.

          There are different failure cases. Basically, does reconnecting to the master require another call to HBaseRPC.getProxy (e.g. yes if the master went down). This only fixes the case that doesn't require another call - e.g. the single RPC call just timed out, but you didn't lose the connection the master. If the master went down and a different master took over then your client is stuck (AFAIK, I'd need to actually test it). This is the same as before HBASE-5058 went in. I kept it this way because of the comment in HBASE-5058:

          The effect is that the current behavior is not changed. I.e. for a managed connection we try only once

          that is, I didn't want to change the behavior.

          What you suggested seems reasonable – I can try that out. Should it be a different patch?

          Lars Hofhansl added a comment -

          I'm fine either way.
          If the connection is managed, there is outside logic that will recreate the connection when there was a failure. Maybe that will take care of a restarted master scenario.

          For an unmanaged connection neither of these problems exist, because we'll just retry.

          Lars Hofhansl added a comment -

          Actually, let's just fix the issue you discovered here. +1 on your patch.
          We can think about the other change I suggest for 0.94.3. It is time to get 0.94.2 out the door.

          Gregory Chanan added a comment -

          Sounds good. I'm doing some cluster testing today, I'll commit if all looks good.

          Lars Hofhansl added a comment -

          Did you find any more weirdness during your testing?

          Gregory Chanan added a comment -

          Haven't been able to get a good run. Is this holding up the new RC for you? I should be able to tell by tomorrow.

          Lars Hofhansl added a comment -

          Yeah, it's the last (for now ) open jira for the next RC.
          Thanks Gregory.

          Lars Hofhansl added a comment -

          <ping>

          Gregory Chanan added a comment -

          Sorry, looks good, going to check in to 0.94.2 soon.

          I need to investigate if this is a problem with 0.96

          Gregory Chanan added a comment -

          Thanks for the reviews, Ted and Lars. Committed to 0.94.

          Not closing until I investigate trunk.

          Lars Hofhansl added a comment -

          Thanks Gregory! ... Will need to resolve temporarily to get correct release notes for 0.94.2 will reopen soon after (or should 0.96 receive a separate issue now?)

          Hudson added a comment -

          Integrated in HBase-0.94 #509 (See https://builds.apache.org/job/HBase-0.94/509/)
          HBASE-6920 On timeout connecting to master, client can get stuck and never make progress (Revision 1394857)

          Result = FAILURE
          gchanan :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/HBaseRPC.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/RpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java
          Hudson added a comment -

          Integrated in HBase-0.94-security #60 (See https://builds.apache.org/job/HBase-0.94-security/60/)
          HBASE-6920 On timeout connecting to master, client can get stuck and never make progress (Revision 1394857)

          Result = FAILURE
          gchanan :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/HBaseRPC.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/RpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java
          Lars Hofhansl added a comment -

          Looks like this is breaking the security build.

          Lars Hofhansl added a comment -

          Addendum to fix the SecureRpcEngine

          Lars Hofhansl added a comment -

          Committed addendum to 0.94

          Hudson added a comment -

          Integrated in HBase-0.94-security #62 (See https://builds.apache.org/job/HBase-0.94-security/62/)
          HBASE-6920 Addendum - fix SecureRpcEngine (Revision 1394908)

          Result = FAILURE
          larsh :
          Files :

          • /hbase/branches/0.94/security/src/main/java/org/apache/hadoop/hbase/ipc/SecureRpcEngine.java
          Hudson added a comment -

          Integrated in HBase-0.94 #511 (See https://builds.apache.org/job/HBase-0.94/511/)
          HBASE-6920 Addendum - fix SecureRpcEngine (Revision 1394908)

          Result = SUCCESS
          larsh :
          Files :

          • /hbase/branches/0.94/security/src/main/java/org/apache/hadoop/hbase/ipc/SecureRpcEngine.java
          Lars Hofhansl added a comment -

          Now TestClientTimeouts always fails in the Security build.

          So, here's what I am going to do: I'll revert the test part of this change, then we can file a new ticket for the 0.96 investigation and the testing part.

          Hudson added a comment -

          Integrated in HBase-0.94-security #73 (See https://builds.apache.org/job/HBase-0.94-security/73/)
          HBASE-6920 Addendum2. Remove test code which does not work for the Secure build (Revision 1395093)

          Result = SUCCESS
          larsh :
          Files :

          • /hbase/branches/0.94/security/src/main/java/org/apache/hadoop/hbase/ipc/SecureRpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/HBaseRPC.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/RpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java
          Hudson added a comment -

          Integrated in HBase-0.94 #512 (See https://builds.apache.org/job/HBase-0.94/512/)
          HBASE-6920 Addendum2. Remove test code which does not work for the Secure build (Revision 1395093)

          Result = ABORTED
          larsh :
          Files :

          • /hbase/branches/0.94/security/src/main/java/org/apache/hadoop/hbase/ipc/SecureRpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/HBaseRPC.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/RpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java
          Gregory Chanan added a comment -

          Sounds good to me Lars. Should have tested the security stuff.

          Lars Hofhansl added a comment -

          The security dependency is not at all obvious. I broke the build before that way

          Fixing the test is probably just a matter of also dealing with SecureRpcEngine (not just WritableRpcEngine).

          Hudson added a comment -

          Integrated in HBase-TRUNK #3472 (See https://builds.apache.org/job/HBase-TRUNK/3472/)
          HBASE-6987 Port HBASE-6920 to trunk (Revision 1401015)

          Result = FAILURE
          gchanan :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #231 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/231/)
          HBASE-6987 Port HBASE-6920 to trunk (Revision 1401015)

          Result = FAILURE
          gchanan :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java
          Hudson added a comment -

          Integrated in HBase-0.94-security-on-Hadoop-23 #9 (See https://builds.apache.org/job/HBase-0.94-security-on-Hadoop-23/9/)
          HBASE-6920 Addendum2. Remove test code which does not work for the Secure build (Revision 1395093)
          HBASE-6920 Addendum - fix SecureRpcEngine (Revision 1394908)
          HBASE-6920 On timeout connecting to master, client can get stuck and never make progress (Revision 1394857)

          Result = FAILURE
          larsh :
          Files :

          • /hbase/branches/0.94/security/src/main/java/org/apache/hadoop/hbase/ipc/SecureRpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/HBaseRPC.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/RpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java

          larsh :
          Files :

          • /hbase/branches/0.94/security/src/main/java/org/apache/hadoop/hbase/ipc/SecureRpcEngine.java

          gchanan :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/HBaseRPC.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/RpcEngine.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/client/TestClientTimeouts.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/ipc/RandomTimeoutRpcEngine.java

            People

            • Assignee:
              Gregory Chanan
              Reporter:
              Gregory Chanan
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development