HBase
  1. HBase
  2. HBASE-6304

TestPBOnWritableRpc#testCalls fails on Hadoop 2.0 build consistently due to NoSuchMethodError

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 0.95.2
    • Fix Version/s: None
    • Component/s: test
    • Labels:
      None

      Description

      mvn test -Dhadoop.profile=2.0 -Dtest=TestPBOnWritrableRpc

      java.lang.NoSuchMethodError: org.apache.hadoop.net.NetUtils.getInputStream(Ljava/net/S
      ocket;)Ljava/io/InputStream;" type="java.io.IOException">java.io.IOException: java.lang.NoSuchMethodError:
       org.apache.hadoop.net.NetUtils.getInputStream(Ljava/net/Socket;)Ljava/io/InputStream;
              at org.apache.hadoop.hbase.ipc.WritableRpcEngine.getProxy(WritableRpcEngine.java:211)
              at org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:336)
              at org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:313)
              at org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:365)
              at org.apache.hadoop.hbase.ipc.HBaseRPC.waitForProxy(HBaseRPC.java:237)
              at org.apache.hadoop.hbase.ipc.TestPBOnWritableRpc.testCallsInternal(TestPBOnWritableRpc.java:98)
              at org.apache.hadoop.hbase.ipc.TestPBOnWritableRpc.testCalls(TestPBOnWritableRpc.java:80)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
              at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
              at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
              at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
              at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:62)
      Caused by: java.lang.NoSuchMethodError: org.apache.hadoop.net.NetUtils.getInputStream(Ljava/net/Socket;)Lj
      ava/io/InputStream;
              at org.apache.hadoop.hbase.ipc.HBaseClient$Connection.setupIOstreams(HBaseClient.java:676)
              at org.apache.hadoop.hbase.ipc.HBaseClient.getConnection(HBaseClient.java:1286)
              at org.apache.hadoop.hbase.ipc.HBaseClient.call(HBaseClient.java:1138)
              at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Invoker.invoke(WritableRpcEngine.java:152)
              at $Proxy10.getProtocolVersion(Unknown Source)
              at org.apache.hadoop.hbase.ipc.WritableRpcEngine.getProxy(WritableRpcEngine.java:196)
              ... 15 more
      

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1h 35m 1 Gregory Chanan 02/Jul/12 21:11
        Gregory Chanan made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Not A Problem [ 8 ]
        Jonathan Hsieh added a comment -

        Sorry seems like a false alarm – need to do a 'mvn clean' when switching profiles to force a recompile.

        Gregory Chanan made changes -
        Field Original Value New Value
        Assignee Gregory Chanan [ gchanan ]
        Jonathan Hsieh created issue -

          People

          • Assignee:
            Gregory Chanan
            Reporter:
            Jonathan Hsieh
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development