HBase
  1. HBase
  2. HBASE-6088

Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.94.0
    • Fix Version/s: 0.94.1, 0.95.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node

      2012-05-24 01:45:41,363 INFO org.apache.zookeeper.ClientCnxn: Client session timed out, have not heard from server in 26668ms for sessionid 0x1377a75f41d0012, closing socket connection and attempting reconnect
      2012-05-24 01:45:41,464 WARN org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper: Possibly transient ZooKeeper exception: org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /hbase/unassigned/bd1079bf948c672e493432020dc0e144
      
      2012-05-24 01:45:43,300 DEBUG org.apache.hadoop.hbase.regionserver.wal.HLog: cleanupCurrentWriter  waiting for transactions to get synced  total 189377 synced till here 189365
      2012-05-24 01:45:48,474 INFO org.apache.hadoop.hbase.regionserver.SplitRequest: Running rollback/cleanup of failed split of ufdr,011365398471659,1337823505339.bd1079bf948c672e493432020dc0e144.; Failed setting SPLITTING znode on ufdr,011365398471659,1337823505339.bd1079bf948c672e493432020dc0e144.
      java.io.IOException: Failed setting SPLITTING znode on ufdr,011365398471659,1337823505339.bd1079bf948c672e493432020dc0e144.
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.createDaughters(SplitTransaction.java:242)
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.execute(SplitTransaction.java:450)
      	at org.apache.hadoop.hbase.regionserver.SplitRequest.run(SplitRequest.java:67)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:662)
      Caused by: org.apache.zookeeper.KeeperException$BadVersionException: KeeperErrorCode = BadVersion for /hbase/unassigned/bd1079bf948c672e493432020dc0e144
      	at org.apache.zookeeper.KeeperException.create(KeeperException.java:115)
      	at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
      	at org.apache.zookeeper.ZooKeeper.setData(ZooKeeper.java:1246)
      	at org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.setData(RecoverableZooKeeper.java:321)
      	at org.apache.hadoop.hbase.zookeeper.ZKUtil.setData(ZKUtil.java:659)
      	at org.apache.hadoop.hbase.zookeeper.ZKAssign.transitionNode(ZKAssign.java:811)
      	at org.apache.hadoop.hbase.zookeeper.ZKAssign.transitionNode(ZKAssign.java:747)
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.transitionNodeSplitting(SplitTransaction.java:919)
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.createNodeSplitting(SplitTransaction.java:869)
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.createDaughters(SplitTransaction.java:239)
      	... 5 more
      2012-05-24 01:45:48,476 INFO org.apache.hadoop.hbase.regionserver.SplitRequest: Successful rollback of failed split of ufdr,011365398471659,1337823505339.bd1079bf948c672e493432020dc0e144.
      
      2012-05-24 01:47:28,141 ERROR org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper: Node /hbase/unassigned/bd1079bf948c672e493432020dc0e144 already exists and this is not a retry
      2012-05-24 01:47:28,142 INFO org.apache.hadoop.hbase.regionserver.SplitRequest: Running rollback/cleanup of failed split of ufdr,011365398471659,1337823505339.bd1079bf948c672e493432020dc0e144.; Failed create of ephemeral /hbase/unassigned/bd1079bf948c672e493432020dc0e144
      java.io.IOException: Failed create of ephemeral /hbase/unassigned/bd1079bf948c672e493432020dc0e144
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.createNodeSplitting(SplitTransaction.java:865)
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.createDaughters(SplitTransaction.java:239)
      	at org.apache.hadoop.hbase.regionserver.SplitTransaction.execute(SplitTransaction.java:450)
      	at org.apache.hadoop.hbase.regionserver.SplitRequest.run(SplitRequest.java:67)
      

      Due to the above exception, region splitting was failing contineously more than 5hrs

      1. addendum_6088_94.patch
        0.9 kB
        ramkrishna.s.vasudevan
      2. HBASE-6088_92.patch
        8 kB
        rajeshbabu
      3. HBASE-6088_94_2.patch
        8 kB
        rajeshbabu
      4. HBASE-6088_94_3.patch
        8 kB
        rajeshbabu
      5. HBASE-6088_94.patch
        8 kB
        rajeshbabu
      6. HBASE-6088_trunk_2.patch
        8 kB
        rajeshbabu
      7. HBASE-6088_trunk_3.patch
        8 kB
        rajeshbabu
      8. HBASE-6088_trunk_4.patch
        8 kB
        rajeshbabu
      9. HBASE-6088_trunk.patch
        8 kB
        rajeshbabu

        Issue Links

          Activity

          stack added a comment -

          The delete of the zk node should provide the sequence id so we don't delete a znode we were not responsible for making.

          This seems radical:

          +    } catch (KeeperException.NoNodeException nn) {
          +      if (abort) {
          +        server.abort("Failed cleanup of " + hri.getRegionNameAsString(), nn);
          +      }
          

          If we don't find our splitting node we abort?

          Good test.

          Hudson added a comment -

          Integrated in HBase-0.92-security #109 (See https://builds.apache.org/job/HBase-0.92-security/109/)
          HBASE-6088 Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node (Rajesh) (Revision 1343819)

          Result = SUCCESS
          ramkrishna :
          Files :

          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/regionserver/SplitTransaction.java
          • /hbase/branches/0.92/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          Hudson added a comment -

          Integrated in HBase-0.94-security #33 (See https://builds.apache.org/job/HBase-0.94-security/33/)
          HBASE-6088 Addendum fixes testSplitBeforeSettingSplittingInZK (Ram) (Revision 1344113)
          HBASE-6088 Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node (Rajesh) (Revision 1343818)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java

          ramkrishna :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/regionserver/SplitTransaction.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          Hudson added a comment -

          Integrated in HBase-0.94 #230 (See https://builds.apache.org/job/HBase-0.94/230/)
          HBASE-6088 Addendum fixes testSplitBeforeSettingSplittingInZK (Ram) (Revision 1344113)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          ramkrishna.s.vasudevan added a comment -

          @Ted
          Thanks a lot.

          Ted Yu added a comment -

          Addendum integrated to 0.94 branch.

          ramkrishna.s.vasudevan added a comment -

          A small addendum for 0.94. Makes TestSplitTransactionOnCluster to pass always. I will be able to commit only in the evening. If the patch is ok, can some one commit it?

          ramkrishna.s.vasudevan added a comment -

          Failure in org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster.testSplitBeforeSettingSplittingInZK in 0.94 is due to the order of the newly added testcase.
          In trunk its not a problem as the master restart related testcases are at the beginning. Will provide an addendum for 0.94 sooner.

          Hudson added a comment -

          Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #31 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/31/)
          HBASE-6088 Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node (Rajesh) (Revision 1343817)

          Result = FAILURE
          ramkrishna :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/SplitTransaction.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          Hudson added a comment -

          Integrated in HBase-0.92 #425 (See https://builds.apache.org/job/HBase-0.92/425/)
          HBASE-6088 Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node (Rajesh) (Revision 1343819)

          Result = FAILURE
          ramkrishna :
          Files :

          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/regionserver/SplitTransaction.java
          • /hbase/branches/0.92/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          Hudson added a comment -

          Integrated in HBase-0.94 #223 (See https://builds.apache.org/job/HBase-0.94/223/)
          HBASE-6088 Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node (Rajesh) (Revision 1343818)

          Result = FAILURE
          ramkrishna :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/regionserver/SplitTransaction.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          Hudson added a comment -

          Integrated in HBase-TRUNK #2943 (See https://builds.apache.org/job/HBase-TRUNK/2943/)
          HBASE-6088 Region splitting not happened for long time due to ZK exception while creating RS_ZK_SPLITTING node (Rajesh) (Revision 1343817)

          Result = SUCCESS
          ramkrishna :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/SplitTransaction.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/regionserver/TestSplitTransactionOnCluster.java
          ramkrishna.s.vasudevan added a comment -

          @Ted
          The committed patch addresses your last comment.

          ramkrishna.s.vasudevan added a comment -

          Committed to 0.92, 0.94 and trunk.
          Thanks for the patch Rajesh.
          Thanks for the review Ted.

          Ted Yu added a comment -

          Minor comment:

          +   * This test case to test the znode is deleted(if created) or not in roll back.
          

          'case to test' -> 'case is to test'

          rajeshbabu added a comment -

          Updated patches as per Ted comments
          Attached patch for 92

          Ted Yu added a comment -

          Makes sense.
          Please make other suggested changes to comment.

          rajeshbabu added a comment -

          @Ted

          The second state should be RS_ZK_REGION_SPLIT.

          As part of createNodeSplitting we transition from RS_ZK_REGION_SPLITTING to RS_ZK_REGION_SPLITTING.

            int transitionNodeSplitting(final ZooKeeperWatcher zkw, final HRegionInfo parent,
                final ServerName serverName, final int version) throws KeeperException, IOException {
              return ZKAssign.transitionNode(zkw, parent, serverName,
                EventType.RS_ZK_REGION_SPLITTING, EventType.RS_ZK_REGION_SPLITTING, version);
            }
          

          Thats why I have mentioned RS_ZK_REGION_SPLITTING as second state.
          Pls correct me if wrong.

          Ted Yu added a comment -
          +   * While transitioning node from RS_ZK_REGION_SPLITTING to
          +   * RS_ZK_REGION_SPLITTING during region split,if zookeper went down split always
          +   * fails for the region.Avoid this by HBASE-6088 fix. 
          +   * This test case to test the znode is deleted(if created) or not in roll back.
          

          The second state should be RS_ZK_REGION_SPLIT.
          Here is rewritten paragraph:

          +   * While transitioning node from RS_ZK_REGION_SPLITTING to
          +   * RS_ZK_REGION_SPLIT during region split, if zookeeper goes down the split always
          +   * fails for the region. HBASE-6088 fixes this scenario. 
          +   * This test case verifies the znode is deleted (if created) or not in roll back.
          
          ramkrishna.s.vasudevan added a comment -

          I am planning to commit this. Pls provide your comments.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12529969/HBASE-6088_94_2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2024//console

          This message is automatically generated.

          rajeshbabu added a comment -

          Updated patch for 94.

          Ted Yu added a comment -

          Thanks for the explanation.

          ramkrishna.s.vasudevan added a comment -

          @Ted
          Basically we changed the static to an instance method so that we can test the split transaction. Infact though it was static the scope was private previously.

          rajeshbabu added a comment -

          @Zhihong Yu
          Thanks for review,

          The above two methods can remain static, right ?

          removed static because we cannot override static methods(but subclass methods hide superclass methods). The version of the hidden method that gets invoked depends on whether it is invoked from the superclass or the subclass.

          Correct me if I am wrong.

          Ted Yu added a comment - - edited
          -  private static int createNodeSplitting(final ZooKeeperWatcher zkw,
          -      final HRegionInfo region, final ServerName serverName)
          -  throws KeeperException, IOException {
          +  int createNodeSplitting(final ZooKeeperWatcher zkw, final HRegionInfo region,
          ...
          +  int transitionNodeSplitting(final ZooKeeperWatcher zkw, final HRegionInfo parent,
          

          The above two methods can remain static, right ?
          For transitionNodeSplitting(), please finish the following javadoc:

          +   * @return
          

          For the test,

          +   * Before setting region in splitting transition if znode may be created and received some
          +   * exception then znode may be present and splitting may not happen,this is to test whether znode
          

          Please rewrite the first sentence above.

          +  public void testSplitBeforeSplittingRegionInTransition() throws IOException,
          

          Rename the above method testSplitBeforeSettingRegionInSplittingTransition() ?

          +  public static class MockedSplitTransaction extends SplitTransaction{
          

          nit: add a space before {

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12529874/HBASE-6088_94.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2010//console

          This message is automatically generated.

          rajeshbabu added a comment -

          Latest patch for trunk and 94

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12529722/HBASE-6088_trunk.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop23. The patch compiles against the hadoop 0.23.x profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 33 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.client.TestFromClientSide
          org.apache.hadoop.hbase.master.TestSplitLogManager

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1995//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1995//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1995//console

          This message is automatically generated.

          rajeshbabu added a comment -

          Attached patch for trunk. Please review and provide suggestions/comments.

          ramkrishna.s.vasudevan added a comment -

          While we start doing the split, there are two steps in zk node creation.
          -> Create the node
          -> Write the data RS_ZK_SPLITTING into it.
          Now after both the steps are completed we make an journal entry.
          Now if writing the data fails even on rollback we are not able to clean the node as we don't know the current journal entry.


            People

            • Assignee:
              rajeshbabu
              Reporter:
              Gopinathan A
            • Votes:
              0 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development