HBase
  1. HBase
  2. HBASE-6041

NullPointerException prevents the master from starting up

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.90.6
    • Fix Version/s: 0.90.7
    • Component/s: master
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      This is 0.90 only.

      2012-05-04 14:27:57,913 FATAL org.apache.hadoop.hbase.master.HMaster: Unhandled exception. Starting shutdown.
      java.lang.NullPointerException
      at org.apache.hadoop.hbase.master.AssignmentManager.regionOnline(AssignmentManager.java:731)
      at org.apache.hadoop.hbase.master.AssignmentManager.processFailover(AssignmentManager.java:215)
      at org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java:419)
      at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:293)
      2012-05-04 14:27:57,914 INFO org.apache.hadoop.hbase.master.HMaster: Aborting
      2012-05-04 14:27:57,915 INFO org.apache.hadoop.ipc.HBaseServer: Stopping server on 1433

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        9m 12s 1 Jimmy Xiang 17/May/12 22:08
        Patch Available Patch Available Resolved Resolved
        4d 21h 47m 1 Ted Yu 22/May/12 19:55
        Ted Yu made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Resolution Fixed [ 1 ]
        Ted Yu added a comment -

        This has been integrated into 0.90

        Ted Yu added a comment -

        Integrated to 0.90 branch.

        Thanks for the patch, Jimmy.

        Jimmy Xiang added a comment -

        Yes, all tests pass. Thanks.

        Ted Yu added a comment -

        Patch looks good.
        Do all tests pass ?

        Jimmy Xiang added a comment -

        The assumption is not true all the time. This is rare. It happened to us once. We could not start the hbase and found this in the master log.
        I checked 92 and trunk code. It doesn't have similar code any more.

        Ted Yu added a comment -

        Can you provide more context for the exception ?
        This is the comment above calls to regionOnline():

            // Add -ROOT- and .META. on regions map.  They must be deployed if we got
            // this far.  Caller takes care of it.
        

        Looks like in your case the above assumption was wrong.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12527922/hbase-6041.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1918//console

        This message is automatically generated.

        Jimmy Xiang made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Jimmy Xiang added a comment -

        The problem is in 0.90 only.

        Jimmy Xiang made changes -
        Fix Version/s 0.90.7 [ 12319481 ]
        Jimmy Xiang made changes -
        Field Original Value New Value
        Attachment hbase-6041.patch [ 12527922 ]
        Jimmy Xiang created issue -

          People

          • Assignee:
            Jimmy Xiang
            Reporter:
            Jimmy Xiang
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development