HBase
  1. HBase
  2. HBASE-5936

Add Column-level PB-based calls to HMasterInterface

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.95.0
    • Component/s: IPC/RPC, master, migration
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      This should be a subtask of HBASE-5445, but since that is a subtask, I can't also make this a subtask (apparently).

      This is for converting the column-level calls, i.e.:
      addColumn
      deleteColumn
      modifyColumn

      1. HBASE-5936.patch
        479 kB
        Gregory Chanan
      2. HBASE-5936-v3.patch
        525 kB
        Gregory Chanan
      3. HBASE-5936-v4.patch
        526 kB
        Gregory Chanan
      4. HBASE-5936-v4.patch
        526 kB
        stack
      5. HBASE-5936-v5.patch
        526 kB
        Gregory Chanan
      6. HBASE-5936-v6.patch
        527 kB
        Gregory Chanan
      7. 5936-addendum-v2.txt
        1 kB
        Ted Yu

        Issue Links

          Activity

          stack added a comment -

          Marking closed.

          Hudson added a comment -

          Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #37 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/37/)
          HBASE-5936 Addendum adds changes for TestHMasterRPCException that were missed in previous checkin (Revision 1345441)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/master/TestHMasterRPCException.java
          Hudson added a comment -

          Integrated in HBase-TRUNK #2974 (See https://builds.apache.org/job/HBase-TRUNK/2974/)
          HBASE-5936 Addendum adds changes for TestHMasterRPCException that were missed in previous checkin (Revision 1345441)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/master/TestHMasterRPCException.java
          stack added a comment -

          Thanks Ted.

          Ted Yu added a comment -

          Addendum v2 integrated to trunk.

          Ted Yu added a comment -

          The exception came out of HBaseRPC.getProxy() call.
          Addendum v2 passes TestHMasterRPCException.

          Ted Yu added a comment -

          Looks like the snippet from patch v6 for TestHMasterRPCException wasn't applied to trunk.
          Addendum attached.

          stack added a comment -

          That seems like easy enough to work around. Any chance of your taking a look Gregory? Separate issue? Thanks boss.

          Ted Yu added a comment -

          I can easily reproduce one of the test failures seen on Jenkins (https://builds.apache.org/view/G-L/view/HBase/job/HBase-TRUNK/2972/testReport/org.apache.hadoop.hbase.master/TestHMasterRPCException/testRPCException/):

          Failed tests:   testRPCException(org.apache.hadoop.hbase.master.TestHMasterRPCException): Unexpected throwable: org.apache.hadoop.hbase.ipc.ServerNotRunningYetException: org.apache.hadoop.hbase.ipc.ServerNotRunningYetException: Server is not running yet
          
          Hudson added a comment -

          Integrated in HBase-TRUNK #2972 (See https://builds.apache.org/job/HBase-TRUNK/2972/)
          HBASE-5936 Add Column-level PB-based calls to HMasterInterface (Revision 1345390)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/HMasterInterface.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/Invocation.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/RequestConverter.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/generated/MasterProtos.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/util/HBaseFsck.java
          • /hbase/trunk/hbase-server/src/main/protobuf/Master.proto
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/util/TestHBaseFsck.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #36 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/36/)
          HBASE-5936 Add Column-level PB-based calls to HMasterInterface (Revision 1345390)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/HMasterInterface.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/Invocation.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/WritableRpcEngine.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/RequestConverter.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/generated/MasterProtos.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/util/HBaseFsck.java
          • /hbase/trunk/hbase-server/src/main/protobuf/Master.proto
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/util/TestHBaseFsck.java
          stack added a comment -

          Committed to trunk. I ran the three failing tests locally and they passed for me w/ this patch applied. Thanks Gregory for your doggedness getting this in.

          Gregory Chanan added a comment -

          I ran these failed tests multiple times locally and they passed.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12530482/HBASE-5936-v6.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to cause Findbugs (version 1.3.9) to fail.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.master.TestHMasterRPCException
          org.apache.hadoop.hbase.regionserver.TestSplitLogWorker
          org.apache.hadoop.hbase.master.TestSplitLogManager

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/2080//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2080//console

          This message is automatically generated.

          Gregory Chanan added a comment -

          Looking at test failures. TestSplitTransactionOnCluster and TestHBaseFsck are fixed in upcoming version.

          TestHMasterRPCException is tricky because is apparently relied on the old exception behavior that I removed.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12530432/HBASE-5936-v4.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to cause Findbugs (version 1.3.9) to fail.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster
          org.apache.hadoop.hbase.master.TestHMasterRPCException
          org.apache.hadoop.hbase.util.TestHBaseFsck

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/2077//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2077//console

          This message is automatically generated.

          Ted Yu added a comment -

          Still no activity.

          stack added a comment -

          See if the just-done little dance triggers hadoopqa

          Gregory Chanan added a comment -
          • Added v4.patch *

          Previous patch was missing this part that I mentioned:
          "Removed some dead code from WritableRpcEngine.java"

          Ted Yu added a comment -

          No Hadoop QA activity so far.

          Probably you need to run the suite yourself.

          Gregory Chanan added a comment -

          I checked with Jimmy and he said the change looks good. Hopefully I managed to kick off HadoopQA again.

          Gregory Chanan added a comment -

          I haven't run this through the full test suite yet, let's see what hadoopQA says.

          Makes the following changes from previous patch:

          • Removed some dead code from WritableRpcEngine.java
          • Converted the offline method used by hbck as well
          • Fix the test case problems. The issue was that HConnectionManager was taking a remote exception (e.g. ServiceException) and throwing the underlying IOException. The problem is the function was declared as throwing a ServiceException, so you get a fun UndeclaredThrowableException and lose the actual underlying exception. Luckily, there were some test cases that checked the actual exception type. I suspect all the RPC conversions we've done had this problem. That said, I'm not sure if Jimmy's stuff relied on the old behavior, so let's see what hadoopQA says.
          Hudson added a comment -

          Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #33 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/33/)
          HBASE-5936 Add Column-level PB-based calls to HMasterInterface; REVERT (Revision 1344449)
          HBASE-5936 Add Column-level PB-based calls to HMasterInterface (Revision 1344433)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/HMasterInterface.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/RequestConverter.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/generated/MasterProtos.java
          • /hbase/trunk/hbase-server/src/main/protobuf/Master.proto

          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/HMasterInterface.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/RequestConverter.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/generated/MasterProtos.java
          • /hbase/trunk/hbase-server/src/main/protobuf/Master.proto
          Hudson added a comment -

          Integrated in HBase-TRUNK #2957 (See https://builds.apache.org/job/HBase-TRUNK/2957/)
          HBASE-5936 Add Column-level PB-based calls to HMasterInterface; REVERT (Revision 1344449)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/HMasterInterface.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/RequestConverter.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/generated/MasterProtos.java
          • /hbase/trunk/hbase-server/src/main/protobuf/Master.proto
          Hudson added a comment -

          Integrated in HBase-TRUNK #2956 (See https://builds.apache.org/job/HBase-TRUNK/2956/)
          HBASE-5936 Add Column-level PB-based calls to HMasterInterface (Revision 1344433)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/client/HConnectionManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/HMasterInterface.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/RequestConverter.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/protobuf/generated/MasterProtos.java
          • /hbase/trunk/hbase-server/src/main/protobuf/Master.proto
          Gregory Chanan added a comment -

          @stack: Sounds good. Working on fix now.

          stack added a comment -

          I backed it out Gregory.

          stack added a comment -

          Let me just reopen this.... altogether. I'll back it out. You can add fix to a new version of the patch Gregory. Thanks.

          stack added a comment -

          @Gregory Yes please. I should have been less enthusiastic about commit. If you can't work on it today, I can back this out.

          Ted Yu added a comment -

          I tried one of the tests listed above and got:

          testExceptionFromCoprocessorWhenCreatingTable(org.apache.hadoop.hbase.coprocessor.TestMasterCoprocessorExceptionWithRemove)  Time elapsed: 0.247 sec  <<< FAILURE!
          java.lang.AssertionError
            at org.junit.Assert.fail(Assert.java:92)
            at org.junit.Assert.assertTrue(Assert.java:43)
            at org.junit.Assert.assertTrue(Assert.java:54)
            at org.apache.hadoop.hbase.coprocessor.TestMasterCoprocessorExceptionWithRemove.testExceptionFromCoprocessorWhenCreatingTable(TestMasterCoprocessorExceptionWithRemove.java:191)
          
          Gregory Chanan added a comment -

          Stack, those test failures appear to be caused by this patch. There's something funky going on with the exception handling. Should I file a new JIRA?

          stack added a comment -

          Committed to trunk. Thanks for the patch Gregory.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12530121/HBASE-5936.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to cause Findbugs (version 1.3.9) to fail.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.coprocessor.TestMasterCoprocessorExceptionWithRemove
          org.apache.hadoop.hbase.client.TestAdmin
          org.apache.hadoop.hbase.master.TestRestartCluster

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/2040//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2040//console

          This message is automatically generated.


            People

            • Assignee:
              Gregory Chanan
              Reporter:
              Gregory Chanan
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development