Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-584

Names in the filter interface are confusing

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • None
    • 0.2.0
    • Filters
    • None

    Description

      I don't like the names of the filter methods in RowFilterInterface. They don't really tell how the methods are being used in the implementation of scanners.

      I'd like to change:

      • filter(Text) to filterRow(...)
      • filter(Text, Text, byte[]) to filterColumn(...)
        and the worst one is
      • filterNotNull(SortedMap<Text, byte[]>). This should be filterRow(Text, SortedMap<Text, byte[]>) (so we add the row key/).

      It may be nice to have timestamps in the methods as well?

      Also the java doc could be cleaned and improved to tell how the filtering is implemented (check rows keys first, then check each individual columns, finally check the assembled row)

      Upon positive feedback, and I'll create a patch.

      Attachments

        1. hbase-584-tests.patch
          12 kB
          Clint Morgan
        2. hbase-584.patch
          17 kB
          Clint Morgan

        Activity

          People

            clint.morgan Clint Morgan
            clint.morgan Clint Morgan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: