HBase
  1. HBase
  2. HBASE-5824

HRegion.incrementColumnValue is not used in trunk

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.95.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      on 0.94 a call to client.HTable#incrementColumnValue will cause HRegion#incrementColumnValue. On trunk all calls to HTable.incrementColumnValue got to HRegion#increment.

      My guess is that HTable#incrementColumnValue and HTable#increment serialize to the same thing over the wire so that the remote HRegionServer no longer knows which htable method was called.

      To repro I checked out trunk and put a break point in HRegion#incrementColumnValue and then ran TestFromClientSide. The breakpoint wasn't hit.

      1. 5824-addendum-v2.txt
        5 kB
        Ted Yu
      2. hbase_5824.addendum
        4 kB
        Jimmy Xiang
      3. hbase-5824_v2.patch
        3 kB
        Jimmy Xiang
      4. hbase-5824.patch
        2 kB
        Jimmy Xiang

        Issue Links

          Activity

          Jimmy Xiang added a comment -

          I will add a unit test for this and fix it.

          Elliott Clark added a comment -

          Thanks.

          Looks like single puts are also only going through the multiput method. I'm not sure if this is an issue that needs to be fixed as well.

          Jimmy Xiang added a comment -

          I looked into it and it seems not a bug. HRegion#incrementColumnValue is a redundant method.
          HRegion#increment can do the same thing. That's why I used HRegion#increment. Anything wrong with that?

          As to the single puts, the reason is that the client side tries to use batch processing. This behaves the
          same as before. Of course, we can enhance it. I will do it in HBASE-5621.

          Jimmy Xiang added a comment -

          This patch is to enhance single puts to use mutate directly instead of multiput.

          For HRegion#incrementColumnValue, I think it is ok not to use it.

          Elliott Clark added a comment -

          Looking through it everything seems to be good. I can't see anything that ICV does that increment doesn't.

          Should the old code get removed then ?

          stack added a comment -

          +1 on the Jimmy patch.

          @Elliott At least add a deprecate pointing to preferred code I'd say?

          Jimmy Xiang added a comment -

          I added a deprecation annotation to HRegion#incrementColumnValue

          Ted Yu added a comment -
          +    if (autoFlush && puts.size() == 1) {
          

          How is autoFlush related to single put ?

          Jimmy Xiang added a comment -

          If autoFlush is not enabled, Puts are most likely batched. It is not very efficient to check if a batch contains only one Put, which is kind of duplicate some of the multiput logic.

          You can say the patch is not strictly for single put.

          Ted Yu added a comment -

          Minor comment:
          The line below exceeds 100 characters.

          +        // we need to periodically see if the writebuffer is full instead of waiting until the end of the List
          
          stack added a comment -

          Committed to trunk. Thanks for patch Jimmy.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12523410/hbase-5824.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 6 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.constraint.TestConstraint
          org.apache.hadoop.hbase.replication.TestReplication
          org.apache.hadoop.hbase.coprocessor.TestRegionServerCoprocessorExceptionWithRemove

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1583//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1583//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1583//console

          This message is automatically generated.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12523412/hbase-5824_v2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 6 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.constraint.TestConstraint
          org.apache.hadoop.hbase.coprocessor.TestRegionServerCoprocessorExceptionWithRemove

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1584//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1584//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1584//console

          This message is automatically generated.

          Ted Yu added a comment -

          I can reproduce one of the test failures reported by Hadoop QA:

          testConstraintFails(org.apache.hadoop.hbase.constraint.TestConstraint)  Time elapsed: 3.174 sec  <<< ERROR!
          org.apache.hadoop.hbase.constraint.ConstraintException: org.apache.hadoop.hbase.constraint.ConstraintException: AllFailConstraint fails for all puts
          ...
          Caused by: org.apache.hadoop.ipc.RemoteException: org.apache.hadoop.hbase.constraint.ConstraintException: AllFailConstraint fails for all puts
            at org.apache.hadoop.hbase.constraint.AllFailConstraint.check(AllFailConstraint.java:29)
            at org.apache.hadoop.hbase.constraint.ConstraintProcessor.prePut(ConstraintProcessor.java:87)
            at org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost.prePut(RegionCoprocessorHost.java:656)
            at org.apache.hadoop.hbase.regionserver.HRegion.internalPut(HRegion.java:2434)
            at org.apache.hadoop.hbase.regionserver.HRegion.put(HRegion.java:1891)
            at org.apache.hadoop.hbase.regionserver.HRegion.put(HRegion.java:1857)
            at org.apache.hadoop.hbase.regionserver.RegionServer.mutate(RegionServer.java:523)
          
          Jimmy Xiang added a comment -

          I am looking into it.

          Hudson added a comment -

          Integrated in HBase-TRUNK #2788 (See https://builds.apache.org/job/HBase-TRUNK/2788/)
          HBASE-5824 HRegion.incrementColumnValue is not used in trunk (Revision 1328142)

          Result = FAILURE
          stack :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTable.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
          Jimmy Xiang added a comment -

          Fixed the unit tests. Sorry for that.

          Ted Yu added a comment -

          +1 on Addendum.
          The two tests pass with addendum:

            542  mt -Dtest=TestConstraint
            543  mt -Dtest=TestRegionServerCoprocessorExceptionWithRemove
          
          Ted Yu added a comment -

          Integrated addendum to TRUNK.

          Thanks for the quick turn around, Jimmy.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12523437/hbase_5824.addendum
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 7 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1588//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1588//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1588//console

          This message is automatically generated.

          Hudson added a comment -

          Integrated in HBase-TRUNK #2790 (See https://builds.apache.org/job/HBase-TRUNK/2790/)
          HBASE-5824 addendum fixes coprocessor tests (Jimmy) (Revision 1328166)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTable.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/coprocessor/TestRegionServerCoprocessorExceptionWithRemove.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-security #176 (See https://builds.apache.org/job/HBase-TRUNK-security/176/)
          HBASE-5824 addendum fixes coprocessor tests (Jimmy) (Revision 1328166)
          HBASE-5824 HRegion.incrementColumnValue is not used in trunk (Revision 1328142)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTable.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/coprocessor/TestRegionServerCoprocessorExceptionWithRemove.java

          stack :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTable.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
          Ted Yu added a comment -

          Implication of this JIRA is that the type of exception thrown when certain constraint isn't satisfied differs depending on whether auto flush is enabled.
          When I changed the test case slightly:

          Index: src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java
          ===================================================================
          --- src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java	(revision 1328376)
          +++ src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java	(working copy)
          @@ -105,7 +105,7 @@
           
               util.getHBaseAdmin().createTable(desc);
               HTable table = new HTable(util.getConfiguration(), tableName);
          -    table.setAutoFlush(true);
          +    table.setAutoFlush(false);
           
               // test that we do fail on violation
               Put put = new Put(row1);
          

          I got:

          testConstraintFails(org.apache.hadoop.hbase.constraint.TestConstraint)  Time elapsed: 4.144 sec  <<< FAILURE!
          java.lang.AssertionError
            at org.junit.Assert.fail(Assert.java:92)
            at org.junit.Assert.assertTrue(Assert.java:43)
            at org.junit.Assert.assertTrue(Assert.java:54)
            at org.apache.hadoop.hbase.constraint.TestConstraint.testConstraintFails(TestConstraint.java:118)
          

          This makes exception handling unnecessarily complicated.

          Ted Yu added a comment -

          Constraint is in 0.94
          This change causes regression in the way client responds to Constraint violation.
          Now client has to deal with two exceptions instead of only one exception (in 0.94)

          stack added a comment -

          This patch only makes sense in trunk, not in 0.94.

          What are the exceptions that now are different?

          Ted Yu added a comment -

          In 0.94, client only needs to deal with RetriesExhaustedWithDetailsException whose only cause is a ConstraintException
          With Jimmy's patch, client needs to deal with RetriesExhaustedWithDetailsException (not subclass of DoNotRetryIOException) and ConstraintException (subclass of DoNotRetryIOException). This is because there're two execution paths for Put.

          I am afraid Benoit would have more to complain about in HBASE-5796

          Jimmy Xiang added a comment -

          Yes, this patch is for 0.96 only.

          RetriesExhaustedWithDetailsException applies to batch processing only.

          For single action, individual exception is used. Currently only Put is implicitly batched.
          Should I change single Put to use RetriesExhaustedWithDetailsException too?

          Ted Yu added a comment -

          Proposed addendum that matches the original intent of the JIRA.
          There is no strong reason for the change in HTable.doPut(final List<Put> puts)

          Ted Yu added a comment -

          @Jimmy:
          Shall we pursue your proposal in a separate JIRA so that we can keep the original intent of this JIRA ?

          Jimmy Xiang added a comment -

          @Ted, I filed HBASE-5845. Thanks for pointing out the issue. Good catch.

          Ted Yu added a comment -

          I talked with Jimmy offline. We agree that single Put execution path isn't of high priority.
          We will leave the discussion and decision making to HBASE-5845.

          Ted Yu added a comment -

          Integrated addendum v2 to trunk.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12523521/5824-addendum-v2.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 7 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1593//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1593//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1593//console

          This message is automatically generated.

          Hudson added a comment -

          Integrated in HBase-TRUNK #2791 (See https://builds.apache.org/job/HBase-TRUNK/2791/)
          HBASE-5824 revert changes to single Put case, preserving deprecation for ICV (Revision 1328457)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTable.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/coprocessor/TestRegionServerCoprocessorExceptionWithRemove.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-security #177 (See https://builds.apache.org/job/HBase-TRUNK-security/177/)
          HBASE-5824 revert changes to single Put case, preserving deprecation for ICV (Revision 1328457)

          Result = FAILURE
          tedyu :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTable.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/constraint/TestConstraint.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/coprocessor/TestRegionServerCoprocessorExceptionWithRemove.java
          stack added a comment -

          Marking closed.


            People

            • Assignee:
              Jimmy Xiang
              Reporter:
              Elliott Clark
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development