HBase
  1. HBase
  2. HBASE-5820

hbck should check fs owner/permissions.

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: hbck
    • Labels:
      None

      Description

      In some cases, hbck needs to be run as a user that has write perms to the file system. If it writes data to hbase's directories, it may write new files/dirs that the hbase processes's user does not have permissions to. We should alert the user of this situation.

        Issue Links

          Activity

          Jonathan Hsieh added a comment -

          This is a dupe of HBASE-5714. Please post discussion and code there.


            People

            • Assignee:
              Jonathan Hsieh
              Reporter:
              Jonathan Hsieh
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development