Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-5735

Clearer warning message when connecting a non-secure HBase client to a secure HBase server

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.92.1, 0.94.0
    • Fix Version/s: 0.92.2, 0.94.0
    • Component/s: security
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When a connection from a non secure-rpc-engine
      client is attempted the warning message you get is related to version
      mismatch:

      Mar 28, 3:27:13 PM WARN org.apache.hadoop.ipc.SecureServer Incorrect
      header or version mismatch from 172.29.82.121:43849 got version 3
      expected version 4

      While this is true, it isn't as useful as it could be. A more specific error message warning end users that they're connecting with a non-secure client may be more useful.

        Attachments

        1. HBASE-5735-v3.patch
          2 kB
          Shaneal Manek
        2. HBASE-5375-v2.patch
          2 kB
          Shaneal Manek
        3. HBASE-5375.patch
          2 kB
          Shaneal Manek

          Activity

            People

            • Assignee:
              smanek Shaneal Manek
              Reporter:
              smanek Shaneal Manek
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: