Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.92.1, 0.94.0
    • Fix Version/s: 0.94.0, 0.95.0
    • Component/s: master
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      A few leftover bugs from HBASE-5209. Comments are documented here:

      https://reviews.apache.org/r/3892/

      1. HBASE-5596.patch
        5 kB
        David S. Wang
      2. hbase-5596-0.94.patch
        5 kB
        Jonathan Hsieh

        Issue Links

          Activity

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12518752/HBASE_5596.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 163 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.master.TestMasterShutdown
          org.apache.hadoop.hbase.master.TestDistributedLogSplitting
          org.apache.hadoop.hbase.client.TestInstantSchemaChangeSplit
          org.apache.hadoop.hbase.client.TestInstantSchemaChangeFailover
          org.apache.hadoop.hbase.master.TestMasterRestartAfterDisablingTable
          org.apache.hadoop.hbase.master.TestMasterFailover
          org.apache.hadoop.hbase.mapreduce.TestImportTsv
          org.apache.hadoop.hbase.mapred.TestTableMapReduce
          org.apache.hadoop.hbase.mapreduce.TestHFileOutputFormat

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1212//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1212//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1212//console

          This message is automatically generated.

          Jonathan Hsieh added a comment -

          Dave,

          Since HBASE-5209 were included in 0.94 and 0.92, it makes sense to include this as well. The current patch seems to only apply to trunk but not to 0.94 and 0.92 branches. Can you update the patch for the other branches?

          Ted Yu added a comment -

          Is this patch ready for integration ?

          From https://builds.apache.org/job/PreCommit-HBASE-Build/1212//testReport/org.apache.hadoop.hbase.client/TestInstantSchemaChangeFailover/testInstantSchemaChangeWhileRSCrash/:

          Caused by: java.lang.RuntimeException: Master not initialized after 200 seconds
          	at org.apache.hadoop.hbase.util.JVMClusterUtil.startup(JVMClusterUtil.java:208)
          	at org.apache.hadoop.hbase.LocalHBaseCluster.startup(LocalHBaseCluster.java:424)
          	at org.apache.hadoop.hbase.MiniHBaseCluster.init(MiniHBaseCluster.java:200)
          
          Jonathan Hsieh added a comment -

          @Ted, I test before committing, but thanks for pointing this out. In my precommit testing the TestInstantSchemaChange* ones seem flakey but legit problems.

          @Dave, mind investigating? I've run into code that had overly strong assumptions about comparators/equality or weak comparators in the past and this might be related to those changes.

          David S. Wang added a comment -

          I'm looking ... probably need to make some changes around the getVersionedBytes()-related calls, as stringifying them seems to be causing the problems. I might end up just putting the versioned info into the ZNode itself similar to how it is done for the masterZNode.

          David S. Wang added a comment -

          Patch against trunk to run through QA robot. If this passes, and folks agree on the change, I'll create patches for 0.94 and 0.92.1 as well.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519550/HBASE-5596.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.coprocessor.TestMasterObserver

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1269//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1269//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1269//console

          This message is automatically generated.

          stack added a comment -

          I took a look at the patch. Mind stating what its supposed to be doing please David? Thanks. Should UNKNOWN_SERVERNAME be a define up in ServerName?

          David S. Wang added a comment -

          Stack, this patch is to address Jon's comments in the reviewboard.

          I'll move UNKNOWN_SERVERNAME up into ServerName and resubmit shortly.

          David S. Wang added a comment -

          Moved UNKNOWN_SERVERNAME to ServerName. Otherwise same patch. Passed all unit tests.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519657/HBASE_5596.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 3 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.master.TestRollingRestart
          org.apache.hadoop.hbase.master.TestMasterShutdown
          org.apache.hadoop.hbase.master.TestDistributedLogSplitting
          org.apache.hadoop.hbase.client.TestInstantSchemaChangeSplit
          org.apache.hadoop.hbase.client.TestInstantSchemaChangeFailover
          org.apache.hadoop.hbase.master.TestMasterRestartAfterDisablingTable
          org.apache.hadoop.hbase.master.TestMasterFailover
          org.apache.hadoop.hbase.mapreduce.TestImportTsv
          org.apache.hadoop.hbase.mapred.TestTableMapReduce
          org.apache.hadoop.hbase.mapreduce.TestHFileOutputFormat

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1277//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1277//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1277//console

          This message is automatically generated.

          David S. Wang added a comment -

          Evidently the tests that passed on my machine failed here. Looking into why this is intermittent.

          David S. Wang added a comment -

          Submitted wrong patch. Sorry.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519676/HBASE-5596.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.replication.TestReplication

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1281//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1281//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1281//console

          This message is automatically generated.

          stack added a comment -

          OK +1. Maybe you want to looksee Jon?

          Jonathan Hsieh added a comment -

          one-line change to apply to 0.94/0.92

          Jonathan Hsieh added a comment -

          +1, lgtm. Since this is an addendum to HBASE-5209, I've tweaked it to work on 0.94 and 0.92. I'll run them through test suites and if they pass tests I'll commit.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519979/hbase-5596-0.94.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1308//console

          This message is automatically generated.

          Jonathan Hsieh added a comment -

          Test came back clean. Committed. Thanks David and thanks for reviews Stack!

          Hudson added a comment -

          Integrated in HBase-0.94-security #3 (See https://builds.apache.org/job/HBase-0.94-security/3/)
          HBASE-5596 Few minor bugs from HBASE-5209 (David S. Wang) (Revision 1305662)

          Result = ABORTED
          jmhsieh :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ClusterStatus.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ServerName.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/ActiveMasterManager.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          Hudson added a comment -

          Integrated in HBase-0.94 #58 (See https://builds.apache.org/job/HBase-0.94/58/)
          HBASE-5596 Few minor bugs from HBASE-5209 (David S. Wang) (Revision 1305662)

          Result = ABORTED
          jmhsieh :
          Files :

          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ClusterStatus.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/ServerName.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/ActiveMasterManager.java
          • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          Hudson added a comment -

          Integrated in HBase-0.92 #340 (See https://builds.apache.org/job/HBase-0.92/340/)
          HBASE-5596 Few minor bugs from HBASE-5209 (David S. Wang) (Revision 1305663)

          Result = FAILURE
          jmhsieh :
          Files :

          • /hbase/branches/0.92/CHANGES.txt
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/ClusterStatus.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/ServerName.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/ActiveMasterManager.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-security #151 (See https://builds.apache.org/job/HBase-TRUNK-security/151/)
          HBASE-5596 Few minor bugs from HBASE-5209 (David S. Wang) (Revision 1305661)

          Result = FAILURE
          jmhsieh :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/ClusterStatus.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/ServerName.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/ActiveMasterManager.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          Hudson added a comment -

          Integrated in HBase-TRUNK #2697 (See https://builds.apache.org/job/HBase-TRUNK/2697/)
          HBASE-5596 Few minor bugs from HBASE-5209 (David S. Wang) (Revision 1305661)

          Result = FAILURE
          jmhsieh :
          Files :

          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/ClusterStatus.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/ServerName.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/ActiveMasterManager.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
          Hudson added a comment -

          Integrated in HBase-0.92-security #104 (See https://builds.apache.org/job/HBase-0.92-security/104/)
          HBASE-5596 Few minor bugs from HBASE-5209 (David S. Wang) (Revision 1305663)

          Result = FAILURE
          jmhsieh :
          Files :

          • /hbase/branches/0.92/CHANGES.txt
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/ClusterStatus.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/ServerName.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/ActiveMasterManager.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/HMaster.java

            People

            • Assignee:
              David S. Wang
              Reporter:
              David S. Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development