Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-5336

Spurious exceptions in HConnectionImplementation

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I have seen this on the client a few time during heave write testing:

      java.util.concurrent.ExecutionException: java.io.IOException: java.io.IOException: java.lang.NullPointerException
      at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
      at java.util.concurrent.FutureTask.get(FutureTask.java:83)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.processBatchCallback(HConnectionManager.java:1524)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.processBatch(HConnectionManager.java:1376)
      at org.apache.hadoop.hbase.client.HTable.flushCommits(HTable.java:891)
      at org.apache.hadoop.hbase.client.HTable.doPut(HTable.java:743)
      at org.apache.hadoop.hbase.client.HTable.put(HTable.java:730)
      at NewsFeedCreate.insert(NewsFeedCreate.java:91)
      at NewsFeedCreate$1.run(NewsFeedCreate.java:38)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: java.io.IOException: java.lang.NullPointerException
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      at org.apache.hadoop.ipc.RemoteException.instantiateException(RemoteException.java:95)
      at org.apache.hadoop.ipc.RemoteException.unwrapRemoteException(RemoteException.java:79)
      at org.apache.hadoop.hbase.client.ServerCallable.translateException(ServerCallable.java:228)
      at org.apache.hadoop.hbase.client.ServerCallable.withoutRetries(ServerCallable.java:212)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation$3.call(HConnectionManager.java:1360)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation$3.call(HConnectionManager.java:1348)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      ... 1 more
      Caused by: org.apache.hadoop.ipc.RemoteException: java.io.IOException: java.lang.NullPointerException
      at org.apache.hadoop.io.SequenceFile$Writer.getLength(SequenceFile.java:1099)
      at org.apache.hadoop.hbase.regionserver.wal.SequenceFileLogWriter.getLength(SequenceFileLogWriter.java:243)
      at org.apache.hadoop.hbase.regionserver.wal.HLog.syncer(HLog.java:1289)
      at org.apache.hadoop.hbase.regionserver.wal.HLog.sync(HLog.java:1386)
      at org.apache.hadoop.hbase.regionserver.HRegion.doMiniBatchPut(HRegion.java:2161)
      at org.apache.hadoop.hbase.regionserver.HRegion.put(HRegion.java:1954)
      at org.apache.hadoop.hbase.regionserver.HRegionServer.multi(HRegionServer.java:3363)
      at sun.reflect.GeneratedMethodAccessor23.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:364)
      at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1326)

      at org.apache.hadoop.hbase.ipc.HBaseClient.call(HBaseClient.java:899)
      at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Invoker.invoke(WritableRpcEngine.java:150)
      at $Proxy1.multi(Unknown Source)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation$3$1.call(HConnectionManager.java:1353)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation$3$1.call(HConnectionManager.java:1351)
      at org.apache.hadoop.hbase.client.ServerCallable.withoutRetries(ServerCallable.java:210)
      ... 7 more

        Issue Links

          Activity

          enis Enis Soztutar added a comment -

          Duplicate of HBASE-5623

          stack stack added a comment -

          Are we calling a sync before a new WAL initialized?

          lhofhansl Lars Hofhansl added a comment -

          Interestingly I find no matching logs on the RegionServers or Datanodes.
          I feel like I have seen a jira about this before, but I cannot find it.


            People

            • Assignee:
              Unassigned
              Reporter:
              lhofhansl Lars Hofhansl
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development