Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.94.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
    • Environment:

      Eclipse Indigo (1.4.1) which includes m2eclipse (1.0 SR1).

    • Hadoop Flags:
      Reviewed

      Description

      The current 'standard' release of Eclipse (indigo) comes with m2eclipse installed. However, as of m2e v1.0, "interesting lifecycle phases" are now handled via a 'connector'. However, several of the plugins we use don't support connectors. This means that eclipse bails out and won't build the project or view it as 'working' even though it builds just fine from the the command line.

      Since Eclipse is one of the major java IDEs and that Indigo has been around for a while, we should make it easy to for new devs to pick up the code and for older devs to upgrade painlessly. The original build should not be modified in any significant way.

        Attachments

        1. mvn_HBASE-5318_r1.patch
          3 kB
          Jesse Yates
        2. mvn_HBASE-5318_r0.patch
          3 kB
          Jesse Yates

          Activity

            People

            • Assignee:
              jesse_yates Jesse Yates
              Reporter:
              jesse_yates Jesse Yates
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: