Details

    • Type: Sub-task Sub-task
    • Status: Patch Available
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 0.94.0
    • Fix Version/s: None
    • Component/s: master
    • Labels:
      None

      Description

      HMasterCommandLine gets a number via -minServers opt. and sets it to a config param "hbase.regions.server.count.min".

      This config is not used anywhere else.

      Perhaps it wants to use "hbase.master.wait.on.regionservers.mintostart" instead?

        Activity

        Harsh J created issue -
        Harsh J made changes -
        Field Original Value New Value
        Attachment HBASE-5145.patch [ 12535624 ]
        Harsh J made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Assignee Harsh J [ qwertymaniac ]
        Hide
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12535624/HBASE-5145.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 9 new or modified tests.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        -1 javac. The applied patch generated 5 javac compiler warnings (more than the trunk's current 4 warnings).

        -1 findbugs. The patch appears to introduce 7 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.regionserver.TestServerCustomProtocol

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//console

        This message is automatically generated.

        Show
        Hadoop QA added a comment - -1 overall. Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12535624/HBASE-5145.patch against trunk revision . +1 @author. The patch does not contain any @author tags. +1 tests included. The patch appears to include 9 new or modified tests. +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile. +1 javadoc. The javadoc tool did not generate any warning messages. -1 javac. The applied patch generated 5 javac compiler warnings (more than the trunk's current 4 warnings). -1 findbugs. The patch appears to introduce 7 new Findbugs (version 1.3.9) warnings. +1 release audit. The applied patch does not increase the total number of release audit warnings. -1 core tests. The patch failed these unit tests: org.apache.hadoop.hbase.regionserver.TestServerCustomProtocol Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//testReport/ Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2350//console This message is automatically generated.
        Hide
        Ted Yu added a comment -

        Here is javadoc for waitForRegionServers():

           * Wait for the region servers to report in.
           * We will wait until one of this condition is met:
           *  - the master is stopped
           *  - the 'hbase.master.wait.on.regionservers.timeout' is reached
           *  - the 'hbase.master.wait.on.regionservers.maxtostart' number of
           *    region servers is reached
           *  - the 'hbase.master.wait.on.regionservers.mintostart' is reached AND
           *   there have been no new region server in for
           *      'hbase.master.wait.on.regionservers.interval' time
        

        If we expose 'hbase.master.wait.on.regionservers.mintostart', we should expose the other parameters as well ?

        Also, the following is difficult to follow:

            opt.addOption("minServers", true, "Minimum RegionServers needed to host user tables");
        

        We should change the wording.

        What do you think ?

        Show
        Ted Yu added a comment - Here is javadoc for waitForRegionServers(): * Wait for the region servers to report in. * We will wait until one of this condition is met: * - the master is stopped * - the 'hbase.master.wait.on.regionservers.timeout' is reached * - the 'hbase.master.wait.on.regionservers.maxtostart' number of * region servers is reached * - the 'hbase.master.wait.on.regionservers.mintostart' is reached AND * there have been no new region server in for * 'hbase.master.wait.on.regionservers.interval' time If we expose 'hbase.master.wait.on.regionservers.mintostart', we should expose the other parameters as well ? Also, the following is difficult to follow: opt.addOption( "minServers" , true , "Minimum RegionServers needed to host user tables" ); We should change the wording. What do you think ?
        Hide
        Harsh J added a comment -

        If we expose 'hbase.master.wait.on.regionservers.mintostart', we should expose the other parameters as well ?

        We already do expose those properties (they are read from configs).

        The plan is to properly make them use constants via HBASE-3274, which I've been slacking on lately but plan to rebase and resume again very soon.

        So for this change, which in reality was only removing the useless minServers' set property and using the right one (a bug), I thought I'll also constantize them as I go.

        We should change the wording.

        Agree, and will do.

        Show
        Harsh J added a comment - If we expose 'hbase.master.wait.on.regionservers.mintostart', we should expose the other parameters as well ? We already do expose those properties (they are read from configs). The plan is to properly make them use constants via HBASE-3274 , which I've been slacking on lately but plan to rebase and resume again very soon. So for this change, which in reality was only removing the useless minServers' set property and using the right one (a bug), I thought I'll also constantize them as I go. We should change the wording. Agree, and will do.

          People

          • Assignee:
            Harsh J
            Reporter:
            Harsh J
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:

              Development