HBase
  1. HBase
  2. HBASE-5016

LoadBalancerFactory - "maser" in package name of dynamically loaded balancer class?

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Shouldn't this... "hbase.maser.loadBalancer.class" be something like "hbase.master.loadBalancer.class"? What's with "maser"?

      
      /**
       * The class that creates a load balancer from a conf.
       */
      public class LoadBalancerFactory {
      
        /**
         * Create a loadblanacer from the given conf.
         * @param conf
         * @return A {@link LoadBalancer}
         */
        public static LoadBalancer getLoadBalancer(Configuration conf) {
      
          // Create the balancer
          Class<? extends LoadBalancer> balancerKlass = conf.getClass("hbase.maser.loadBalancer.class",DefaultLoadBalancer.class, LoadBalancer.class);
          return ReflectionUtils.newInstance(balancerKlass, conf);
      
        }
      }
      

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Doug Meil
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development