HBase
  1. HBase
  2. HBASE-4946

HTable.coprocessorExec (and possibly coprocessorProxy) does not work with dynamically loaded coprocessors (from hdfs or local system), because the RPC system tries to deserialize an unknown class.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.92.0
    • Fix Version/s: 0.92.0, 0.94.0
    • Component/s: Coprocessors
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Loading coprocessors jars from hdfs works fine. I load it from the shell, after setting the attribute, and it gets loaded:

      INFO org.apache.hadoop.hbase.regionserver.HRegion: Setting up tabledescriptor config now ...
      INFO org.apache.hadoop.hbase.coprocessor.CoprocessorHost: Class com.MyCoprocessorClass needs to be loaded from a file - hdfs://localhost:9000/coproc/rt-      >0.0.1-SNAPSHOT.jar.
      INFO org.apache.hadoop.hbase.coprocessor.CoprocessorHost: loadInstance: com.MyCoprocessorClass
      INFO org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost: RegionEnvironment createEnvironment
      DEBUG org.apache.hadoop.hbase.regionserver.HRegion: Registered protocol handler: region=t1,,1322572939753.6409aee1726d31f5e5671a59fe6e384f. protocol=com.MyCoprocessorClassProtocol
      INFO org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost: Load coprocessor com.MyCoprocessorClass from HTD of t1 successfully.
      

      The problem is that this coprocessors simply extends BaseEndpointCoprocessor, with a dynamic method. When calling this method from the client with HTable.coprocessorExec, I get errors on the HRegionServer, because the call cannot be deserialized from writables.

      The problem is that Exec tries to do an "early" resolve of the coprocessor class. The coprocessor class is loaded, but it is in the context of the HRegionServer / HRegion. So, the call fails:

      2011-12-02 00:34:17,348 ERROR org.apache.hadoop.hbase.io.HbaseObjectWritable: Error in readFields
      java.io.IOException: Protocol class com.MyCoprocessorClassProtocol not found
        at org.apache.hadoop.hbase.client.coprocessor.Exec.readFields(Exec.java:125)
        at org.apache.hadoop.hbase.io.HbaseObjectWritable.readObject(HbaseObjectWritable.java:575)
        at org.apache.hadoop.hbase.ipc.Invocation.readFields(Invocation.java:105)
        at org.apache.hadoop.hbase.ipc.HBaseServer$Connection.processData(HBaseServer.java:1237)
        at org.apache.hadoop.hbase.ipc.HBaseServer$Connection.readAndProcess(HBaseServer.java:1167)
        at org.apache.hadoop.hbase.ipc.HBaseServer$Listener.doRead(HBaseServer.java:703)
        at org.apache.hadoop.hbase.ipc.HBaseServer$Listener$Reader.doRunLoop(HBaseServer.java:495)
        at org.apache.hadoop.hbase.ipc.HBaseServer$Listener$Reader.run(HBaseServer.java:470)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.ClassNotFoundException: com.MyCoprocessorClassProtocol
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:247)
        at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:943)
        at org.apache.hadoop.hbase.client.coprocessor.Exec.readFields(Exec.java:122)
        ... 10 more
      

      Probably the correct way to fix this is to make Exec really smart, so that it knows all the class definitions loaded in CoprocessorHost(s).

      I created a small patch that simply doesn't resolve the class definition in the Exec, instead passing it as string down to the HRegion layer. This layer knows all the definitions, and simply loads it by name.

      1. 4946-v5.txt
        6 kB
        Ted Yu
      2. 4946-v4.txt
        6 kB
        Ted Yu
      3. HBASE-4946-v3.patch
        6 kB
        Andrei Dragomir
      4. HBASE-4946-v2.patch
        7 kB
        Andrei Dragomir
      5. HBASE-4946.patch
        4 kB
        Andrei Dragomir

        Activity

        Andrei Dragomir added a comment -

        There is no test for now, because TestDynamicClassLoading fails on my machie locally (will investigate). Also, protocolHandlerNames could be a premature optimization.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12506025/HBASE-4946.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 javadoc. The javadoc tool appears to have generated -160 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 72 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.TestDrainingServer
        org.apache.hadoop.hbase.TestFullLogReconstruction

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/441//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/441//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/441//console

        This message is automatically generated.

        Andrew Purtell added a comment -

        Thanks for the patch Andrei, looks good. I gather from your comment above that another version is forthcoming that contains a unit test, will hold off full testing and commit until then.

        Andrei Dragomir added a comment -

        Added unit test for Exec deserialization.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12506101/HBASE-4946-v2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 javadoc. The javadoc tool appears to have generated -160 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 72 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.client.TestAdmin
        org.apache.hadoop.hbase.client.TestInstantSchemaChange

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/443//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/443//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/443//console

        This message is automatically generated.

        Ted Yu added a comment -

        The change in BloomFilterFactory is unrelated, please remove it from patch.

        Andrei Dragomir added a comment -

        Removed unrelated change on BloomFilterFactory

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12506111/HBASE-4946-v3.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 javadoc. The javadoc tool appears to have generated -160 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 72 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.mapreduce.TestTimeRangeMapRed
        org.apache.hadoop.hbase.mapreduce.TestLoadIncrementalHFilesSplitRecovery
        org.apache.hadoop.hbase.TestDrainingServer
        org.apache.hadoop.hbase.TestFullLogReconstruction
        org.apache.hadoop.hbase.mapreduce.TestImportTsv
        org.apache.hadoop.hbase.mapreduce.TestTableMapReduce

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/444//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/444//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/444//console

        This message is automatically generated.

        Ted Yu added a comment -

        The failed tests were due to 'unable to create new native thread'

        Ted Yu added a comment -

        For coprocessor/Exec.java, javadoc doesn't match code:

             try {
               protocol = (Class<CoprocessorProtocol>)conf.getClassByName(protocolName);
             }
             catch (ClassNotFoundException cnfe) {
        -      throw new IOException("Protocol class "+protocolName+" not found", cnfe);
        +      // can't do eager instantiation. pass it as a string and try to deserialize later.
        +      //throw new IOException("Protocol class "+protocolName+" not found", cnfe);
        

        I think the above try block should be commented out.
        TestCoprocessorEndpoint passes without the above assignment to protocol.

        Ted Yu added a comment -

        Patch v4 removes eager instantiation.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12506521/4946-v4.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 javadoc. The javadoc tool appears to have generated -160 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 73 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/468//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/468//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/468//console

        This message is automatically generated.

        Ted Yu added a comment -

        Will commit patch v4 tomorrow.

        Lars Hofhansl added a comment -

        Please don't comment out code, but remove it instead. We have a record of the old code still in source control.

        Ted Yu added a comment -

        Patch v5 removes commented out code.

        Lars Hofhansl added a comment -

        +1 v5 lgtm

        stack added a comment -

        This belongs in 0.92 too?

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12506703/4946-v5.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 javadoc. The javadoc tool appears to have generated -160 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        -1 findbugs. The patch appears to introduce 75 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/479//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/479//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/479//console

        This message is automatically generated.

        Ted Yu added a comment -

        Integrated to 0.92 and TRUNK.

        Thanks for the patch Andrei.

        Thanks for the review Lars and Stack.

        Hudson added a comment -

        Integrated in HBase-TRUNK #2532 (See https://builds.apache.org/job/HBase-TRUNK/2532/)
        HBASE-4946 HTable.coprocessorExec (and possibly coprocessorProxy) does not work with
        dynamically loaded coprocessors (Andrei Dragomir)

        tedyu :
        Files :

        • /hbase/trunk/CHANGES.txt
        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/coprocessor/Exec.java
        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/coprocessor/TestCoprocessorEndpoint.java
        Hudson added a comment -

        Integrated in HBase-0.92-security #34 (See https://builds.apache.org/job/HBase-0.92-security/34/)
        HBASE-4946 HTable.coprocessorExec (and possibly coprocessorProxy) does not work with
        dynamically loaded coprocessors (Andrei Dragomir)

        tedyu :
        Files :

        • /hbase/branches/0.92/CHANGES.txt
        • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/client/coprocessor/Exec.java
        • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/branches/0.92/src/test/java/org/apache/hadoop/hbase/coprocessor/TestCoprocessorEndpoint.java
        Hudson added a comment -

        Integrated in HBase-TRUNK-security #26 (See https://builds.apache.org/job/HBase-TRUNK-security/26/)
        HBASE-4946 HTable.coprocessorExec (and possibly coprocessorProxy) does not work with
        dynamically loaded coprocessors (Andrei Dragomir)

        tedyu :
        Files :

        • /hbase/trunk/CHANGES.txt
        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/coprocessor/Exec.java
        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/coprocessor/TestCoprocessorEndpoint.java
        Hudson added a comment -

        Integrated in HBase-0.92 #180 (See https://builds.apache.org/job/HBase-0.92/180/)
        HBASE-4946 HTable.coprocessorExec (and possibly coprocessorProxy) does not work with
        dynamically loaded coprocessors (Andrei Dragomir)

        tedyu :
        Files :

        • /hbase/branches/0.92/CHANGES.txt
        • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/client/coprocessor/Exec.java
        • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/branches/0.92/src/test/java/org/apache/hadoop/hbase/coprocessor/TestCoprocessorEndpoint.java
        stack added a comment -

        committed branch and trunk.


          People

          • Assignee:
            Andrei Dragomir
            Reporter:
            Andrei Dragomir
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development